aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 6 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 1b10f0c..24fa0cb 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -37,6 +37,11 @@ else()
add_definitions("-Wall")
endif()
+# Thread fix for old CMake
+
+set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -pthread")
+set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -pthread")
+
# Check for prerequisites
set(DEPS glib-2.0>=2.58 gtk+-3.0>=3.24)
@@ -47,7 +52,7 @@ pkg_check_modules(PROJECT_DEPS REQUIRED ${DEPS})
# Set global variables
include(GNUInstallDirs)
-set(PROJECT_VERSION "0.9.1")
+set(PROJECT_VERSION "0.10.2")
# Make everything