aboutsummaryrefslogtreecommitdiff
path: root/example/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'example/Makefile.am')
-rw-r--r--example/Makefile.am10
1 files changed, 8 insertions, 2 deletions
diff --git a/example/Makefile.am b/example/Makefile.am
index 7e76434..b986b9b 100644
--- a/example/Makefile.am
+++ b/example/Makefile.am
@@ -1,3 +1,9 @@
+if USE_GTK3
+VER=3
+else
+VER=
+endif
+
noinst_PROGRAMS = \
messagedialog \
menus
@@ -24,6 +30,6 @@ menus_CPPFLAGS = \
$(GTK_CFLAGS) \
$(MAINTAINER_CFLAGS)
-messagedialog_LDADD = $(top_builddir)/src/libido-0.1.la $(GTK_LIBS)
+messagedialog_LDADD = $(top_builddir)/src/libido$(VER)-0.1.la $(GTK_LIBS)
-menus_LDADD = $(top_builddir)/src/libido-0.1.la $(GTK_LIBS)
+menus_LDADD = $(top_builddir)/src/libido$(VER)-0.1.la $(GTK_LIBS)