aboutsummaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am44
1 files changed, 43 insertions, 1 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index e0b73f5..8fded37 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -1 +1,43 @@
-# Testing, one, two, three
+
+check_LIBRARIES = libgtest.a
+check_PROGRAMS =
+TESTS =
+
+AM_CPPFLAGS = \
+ $(GTEST_CPPFLAGS) \
+ -I${top_srcdir}/src
+
+#############################
+# Google Test base library
+#############################
+
+nodist_libgtest_a_SOURCES = \
+ $(GTEST_SOURCE)/src/gtest-all.cc \
+ $(GTEST_SOURCE)/src/gtest_main.cc
+libgtest_a_CPPFLAGS = \
+ $(GTEST_CPPFLAGS) -w
+libgtest_a_CXXFLAGS = \
+ $(AM_CXXFLAGS)
+libgtest_a_CPPFLAGS = \
+ $(AM_CPPFLAGS)
+
+#############################
+# Menuitem tests
+#############################
+
+TESTS += gtest-menuitems
+check_PROGRAMS += gtest-menuitems
+
+gtest_menuitems_SOURCES = \
+ gtest-menuitems.cpp
+gtest_menuitems_CPPFLAGS = \
+ $(GCC_CFLAGS) \
+ $(GTK_CFLAGS) \
+ $(MAINTAINER_CFLAGS) \
+ $(AM_CPPFLAGS)
+gtest_menuitems_LDFLAGS = \
+ -pthread
+gtest_menuitems_LDADD = \
+ $(GTK_LIBS) \
+ libgtest.a
+