aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMike Gabriel <mike.gabriel@das-netzwerkteam.de>2021-05-25 13:01:26 +0200
committerMike Gabriel <mike.gabriel@das-netzwerkteam.de>2021-05-25 13:01:26 +0200
commitfe5ae6b69f0d98a26735f8d42859a08f788215ce (patch)
tree3667f9fdd463a8824a14e77820efeec151437a01 /CMakeLists.txt
parentdd675b4d9d02b73969ab47ed6a8ed4a13ea2cfa5 (diff)
parentb9a91db2f5ff1655270bc4943debd6bdfa550036 (diff)
downloadayatana-indicator-application-fe5ae6b69f0d98a26735f8d42859a08f788215ce.tar.gz
ayatana-indicator-application-fe5ae6b69f0d98a26735f8d42859a08f788215ce.tar.bz2
ayatana-indicator-application-fe5ae6b69f0d98a26735f8d42859a08f788215ce.zip
Merge branch 'tari01-pr/move-to-cmake'
Attributes GH PR #7: https://github.com/AyatanaIndicators/ayatana-indicator-application/pull/7
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt55
1 files changed, 55 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
new file mode 100644
index 0000000..dfc1576
--- /dev/null
+++ b/CMakeLists.txt
@@ -0,0 +1,55 @@
+cmake_minimum_required(VERSION 3.13)
+project(ayatana-appindicator-application C)
+
+if(CMAKE_INSTALL_PREFIX_INITIALIZED_TO_DEFAULT)
+ SET(CMAKE_INSTALL_PREFIX "/usr" CACHE PATH "..." FORCE)
+endif(CMAKE_INSTALL_PREFIX_INITIALIZED_TO_DEFAULT)
+
+option(ENABLE_TESTS "Enable all tests and checks" OFF)
+option(ENABLE_COVERAGE "Enable coverage reports (includes enabling all tests and checks)" OFF)
+
+if(ENABLE_COVERAGE)
+ set(ENABLE_TESTS ON)
+ set(CMAKE_BUILD_TYPE "Coverage")
+else()
+ set(CMAKE_BUILD_TYPE "Release")
+endif()
+
+# Check for prerequisites
+
+set(CMAKE_BUILD_TYPE "Release")
+find_package(PkgConfig REQUIRED)
+pkg_check_modules(PROJECT_DEPS REQUIRED glib-2.0>=2.58 ayatana-indicator3-0.4>=0.6.2 gtk+-3.0>=3.24 ayatana-appindicator3-0.1>=0.5.3 dbus-glib-1>=0.110 dbusmenu-gtk3-0.4)
+
+# Set global variables
+
+include(GNUInstallDirs)
+set(PROJECT_VERSION "0.8.0")
+set(PROJECT_NAME "ayatana-appindicator-application")
+
+if("${CMAKE_CXX_COMPILER_ID}" STREQUAL "Clang")
+
+ set(COMPILE_FLAGS "${COMPILE_FLAGS} -Weverything")
+ set(COMPILE_FLAGS "${COMPILE_FLAGS} -Wno-c++98-compat -Wno-padded")
+ set(COMPILE_FLAGS "${COMPILE_FLAGS} -Wno-documentation")
+
+else()
+
+ set(COMPILE_FLAGS "${COMPILE_FLAGS} -Wall")
+
+endif()
+
+# Make everything
+
+add_subdirectory(data)
+add_subdirectory(src)
+
+if (ENABLE_TESTS)
+ include(CTest)
+ enable_testing()
+endif()
+
+# Display config info
+
+message(STATUS "Install prefix: ${CMAKE_INSTALL_PREFIX}")
+message(STATUS "Unit tests: ${ENABLE_TESTS}")