aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTed Gould <ted@gould.cx>2012-02-08 11:28:29 -0600
committerTed Gould <ted@gould.cx>2012-02-08 11:28:29 -0600
commit22965953b89a0ed229c9009a2750c573d82acfee (patch)
treee11888e89498c6e8de40c66738d6d8f4db943e5b /configure.ac
parent61ce1240559e39b4ef2ff6d28b9a202bd8e45ff8 (diff)
parent8c0ecc8e811e697b208779be157c78378cfba2d3 (diff)
downloadayatana-indicator-application-22965953b89a0ed229c9009a2750c573d82acfee.tar.gz
ayatana-indicator-application-22965953b89a0ed229c9009a2750c573d82acfee.tar.bz2
ayatana-indicator-application-22965953b89a0ed229c9009a2750c573d82acfee.zip
Import upstream version 0.4.90
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 13 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 33a6260..18c918c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,11 +1,11 @@
-AC_INIT(indicator-application, 0.4.0, ted@canonical.com)
+AC_INIT(indicator-application, 0.4.90, ted@canonical.com)
AC_COPYRIGHT([Copyright 2009, 2010 Canonical])
AC_PREREQ(2.53)
AM_CONFIG_HEADER(config.h)
-AM_INIT_AUTOMAKE(indicator-application, 0.4.0)
+AM_INIT_AUTOMAKE(indicator-application, 0.4.90)
AM_MAINTAINER_MODE
@@ -33,7 +33,7 @@ GTK_REQUIRED_VERSION=2.18
GTK3_REQUIRED_VERSION=2.91
GIO_REQUIRED_VERSION=2.26
INDICATOR_REQUIRED_VERSION=0.3.5
-DBUSMENUGTK_REQUIRED_VERSION=0.3.91
+DBUSMENUGTK_REQUIRED_VERSION=0.5.90
JSON_GLIB_REQUIRED_VERSION=0.7.6
DBUS_GLIB_REQUIRED_VERSION=0.82
@@ -70,6 +70,15 @@ AS_IF([test "x$with_gtk" = x3],
)
AM_CONDITIONAL(USE_GTK3, [test "x$with_gtk" = x3])
+###########################
+# gcov coverage reporting
+###########################
+m4_include([m4/gcov.m4])
+AC_TDD_GCOV
+AC_SUBST(COVERAGE_CFLAGS)
+AC_SUBST(COVERAGE_CXXFLAGS)
+AC_SUBST(COVERAGE_LDFLAGS)
+
AC_SUBST(INDICATOR_CFLAGS)
AC_SUBST(INDICATOR_LIBS)
@@ -134,4 +143,5 @@ Application Indicator Configuration:
Prefix: $prefix
Indicator Dir: $INDICATORDIR
GTK+ Version: $with_gtk
+ gcov: $use_gcov
])