aboutsummaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorKen VanDine <ken.vandine@canonical.com>2009-12-16 14:37:40 -0500
committerKen VanDine <ken.vandine@canonical.com>2009-12-16 14:37:40 -0500
commit2a5cad3851390bf7a875d40cb525ddbe6ec8a6c2 (patch)
tree53181f5ab087552e3b9c026972f80015860e34a5 /debian/rules
parent53d5f10ac0667f455de2b3e5553647545345b062 (diff)
downloadayatana-indicator-application-2a5cad3851390bf7a875d40cb525ddbe6ec8a6c2.tar.gz
ayatana-indicator-application-2a5cad3851390bf7a875d40cb525ddbe6ec8a6c2.tar.bz2
ayatana-indicator-application-2a5cad3851390bf7a875d40cb525ddbe6ec8a6c2.zip
* debian/rules
- don't use gnome.mk, specify all the targets to build python bindings for each supported python version * Adding in Python bindings. * debian/control, debian/python-appindicator.install: Building a binary package for the python bindings. * debian/control: Adding python building build deps
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules56
1 files changed, 54 insertions, 2 deletions
diff --git a/debian/rules b/debian/rules
index 1d2f7dd..41fbfb0 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,12 +1,64 @@
#!/usr/bin/make -f
+
+DEB_PYTHON_SYSTEM=pycentral
+PY_VERSIONS = $(shell pyversions --requested debian/control)
+
include /usr/share/cdbs/1/rules/debhelper.mk
-include /usr/share/cdbs/1/class/gnome.mk
+include /usr/share/cdbs/1/class/autotools-vars.mk
include /usr/share/cdbs/1/rules/simple-patchsys.mk
DEB_CONFIGURE_EXTRA_FLAGS += --enable-gtk-doc
-LDFLAGS += -Wl,-z,defs -Wl,--as-needed
+
+configure-stamp-%:
+ mkdir build-$*
+ cd build-$* && PYTHON=`which $*` \
+ $(DEB_CONFIGURE_SCRIPT) $(DEB_CONFIGURE_NORMAL_ARGS) --srcdir=..
+ touch $@
+
+configure/python-appindicator:: $(addprefix configure-stamp-, $(PY_VERSIONS))
+
+build-stamp-%:
+ make -C build-$*/python
+ touch $@
+
+build/python-appindicator:: $(addprefix build-stamp-, $(PY_VERSIONS))
+
+install-stamp-%:
+ make -C build-$*/python install DESTDIR=$(CURDIR)/debian/tmp
+ touch $@
+
+install/python-appindicator:: $(addprefix install-stamp-, $(PY_VERSIONS))
+
+
+binary-install/python-appindicator::
+ dh_pycentral
+
+configure-stamp:
+ $(DEB_CONFIGURE_SCRIPT) $(DEB_CONFIGURE_NORMAL_ARGS) $(DEB_CONFIGURE_EXTRA_FLAGS)
+ touch $@
+
+configure/indicator-application:: configure-stamp
+
+build-stamp:
+ make
+ touch $@
+
+build/indicator-application:: build-stamp
+
+install-stamp:
+ make install DESTDIR=$(CURDIR)/debian/tmp
+ touch $@
+
+install/indicator-application:: install-stamp
binary-post-install/indicator-application::
find debian/indicator-application/usr/lib -name \*.la -exec rm {} \;
find debian/indicator-application/usr/lib -name \*.a -exec rm {} \;
+
+clean::
+ -rm -rf $(addprefix build-, $(PY_VERSIONS))
+ -rm -rf $(addprefix configure-stamp-, $(PY_VERSIONS))
+ -rm -rf $(addprefix build-stamp-, $(PY_VERSIONS))
+ -rm -rf $(addprefix install-stamp-, $(PY_VERSIONS))
+