aboutsummaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorSebastien Bacher <seb128@ubuntu.com>2012-08-22 13:59:58 +0200
committerSebastien Bacher <seb128@ubuntu.com>2012-08-22 13:59:58 +0200
commita89e5ccd235f75596967536d98cce49045d8ede6 (patch)
tree07fba738fea7e846cb442490d666d688da0f1c77 /debian/rules
parented31788a3809cc5fd630f4a5465cd7e6aa90586b (diff)
parent9df80bfc9af46dc8a611450b80b599d988596d11 (diff)
downloadayatana-indicator-application-a89e5ccd235f75596967536d98cce49045d8ede6.tar.gz
ayatana-indicator-application-a89e5ccd235f75596967536d98cce49045d8ede6.tar.bz2
ayatana-indicator-application-a89e5ccd235f75596967536d98cce49045d8ede6.zip
* New upstream release:
- Require GTK3 in Indicators (lp: #996607) * Dropped GTK2 build * Updated packaging to the current standards
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules28
1 files changed, 6 insertions, 22 deletions
diff --git a/debian/rules b/debian/rules
index 0c35db9..8e07208 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,25 +1,9 @@
#!/usr/bin/make -f
-DEB_BUILDDIR = build
-DEB_MAKE_FLAVORS = gtk2 gtk3
-
-include /usr/share/cdbs/1/rules/debhelper.mk
-include /usr/share/cdbs/1/class/gnome.mk
-
-DEB_MAKE_DESTDIRSKEL = $(CURDIR)/debian/tmp/@FLAVOR@
-DEB_DESTDIR = $(CURDIR)/debian/tmp/$(cdbs_make_curflavor)/
-
-DEB_CONFIGURE_FLAGS_gtk2 = --with-gtk=2
-DEB_CONFIGURE_FLAGS_gtk3 = --with-gtk=3
-DEB_CONFIGURE_EXTRA_FLAGS = --disable-static
-
-LDFLAGS += -Wl,-z,defs -Wl,--as-needed
-
-debian/stamp-autotools/gtk2: cdbs_configure_flags += $(DEB_CONFIGURE_FLAGS_gtk2)
-debian/stamp-autotools/gtk3: cdbs_configure_flags += $(DEB_CONFIGURE_FLAGS_gtk3)
-
-common-install-arch::
- find debian/tmp -name \*.la -delete
- find debian/tmp -name \*.a -delete
- cd po; intltool-update --pot --verbose
+%:
+ dh $@ --with translations
+override_dh_install:
+ find debian/indicator-application/usr/lib -name *.la -delete
+ find debian/indicator-application/usr/lib -name *.a -delete
+ dh_install --fail-missing