aboutsummaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorKen VanDine <ken.vandine@canonical.com>2010-12-10 18:05:00 -0500
committerKen VanDine <ken.vandine@canonical.com>2010-12-10 18:05:00 -0500
commitbc0f5cc4c4fbf12ec5a9441ea3e69a1edcf066e4 (patch)
tree215b04c7c9ab18ff31a81a327292b46f85b6cccf /debian/rules
parent1f80de2bdc26fb3b0e432ef154a968abee596abf (diff)
downloadayatana-indicator-application-bc0f5cc4c4fbf12ec5a9441ea3e69a1edcf066e4.tar.gz
ayatana-indicator-application-bc0f5cc4c4fbf12ec5a9441ea3e69a1edcf066e4.tar.bz2
ayatana-indicator-application-bc0f5cc4c4fbf12ec5a9441ea3e69a1edcf066e4.zip
releasing version 0.2.90+r170-0ubuntu1
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules92
1 files changed, 2 insertions, 90 deletions
diff --git a/debian/rules b/debian/rules
index cfb2f4b..80009dd 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,97 +1,9 @@
#!/usr/bin/make -f
-DEB_SRCDIR = .
-DEB_BUILDDIR = $(DEB_SRCDIR)/build
-
-DEB_PYTHON_SYSTEM=dh_python2
-PY_VERSIONS = $(shell pyversions --requested debian/control)
-export MONO_SHARED_DIR=$(CURDIR)
-export CSC=/usr/bin/mono-csc
-
include /usr/share/cdbs/1/rules/debhelper.mk
-include /usr/share/cdbs/1/class/autotools-vars.mk
+include /usr/share/cdbs/1/class/gnome.mk
include /usr/share/cdbs/1/rules/utils.mk
-DEB_CONFIGURE_EXTRA_FLAGS += --enable-gtk-doc
-API_VERSION = 0.1
-
-DEB_DH_MAKESHLIBS_ARGS_libappindicator1 := -V 'libappindicator1 (>= 0.0.19)'
-
-configure-stamp-%:
- mkdir build-$*
- cd build-$* && PYTHON=`which $*` \
- $(DEB_CONFIGURE_SCRIPT) $(DEB_CONFIGURE_NORMAL_ARGS) --srcdir=..
- touch $@
-
-configure/python-appindicator:: $(addprefix configure-stamp-, $(PY_VERSIONS))
-
-build-stamp-%:
- PYTHON=`which $*` \
- $(MAKE) -C build-$*
- touch $@
-
-build/python-appindicator:: $(addprefix build-stamp-, $(PY_VERSIONS))
-
-install-stamp-%:
- PYTHON=`which $*` \
- $(MAKE) -C build-$*/bindings/python install DESTDIR=$(CURDIR)/debian/tmp
- dh_installdirs -ppython-appindicator -s
- dh_install -ppython-appindicator -s
- touch $@
-
-install/python-appindicator:: $(addprefix install-stamp-, $(PY_VERSIONS))
-
-binary-predeb/python-appindicator::
- dh_python2 -ppython-appindicator
- find debian/python-appindicator/usr/lib -name \*.la -exec rm {} \;
- find debian/python-appindicator/usr/lib -name \*.a -exec rm {} \;
-
-binary-install/libappindicator0.1-cil::
- dh_clistrip
- dh_clifixperms
- dh_makeclilibs -V
- dh_installcligac
-
-binary-predeb/gir1.0-appindicator-0.1::
- dh_girepository -p$(cdbs_curpkg)
-
-binary-predeb/libappindicator0.1-cil:: binary-fixup/libappindicator1
- dh_clideps -plibappindicator0.1-cil
-
-configure-stamp:
- cd $(DEB_BUILDDIR) && \
- $(DEB_CONFIGURE_SCRIPT) $(DEB_CONFIGURE_NORMAL_ARGS) $(DEB_CONFIGURE_EXTRA_FLAGS)
- touch $@
-
-configure/indicator-application:: configure-stamp
-
-build-stamp:
- $(MAKE) -C $(DEB_BUILDDIR)
- touch $@
-
-build/indicator-application:: build-stamp
-
-install-stamp:
- $(MAKE) -C $(DEB_BUILDDIR) install DESTDIR=$(CURDIR)/debian/tmp
- touch $@
-
-install/indicator-application:: install-stamp
-
-binary-predeb/libappindicator1:: install-stamp
- dh_fixperms
- dh_strip
-
-binary-post-install/indicator-application::
- find debian/indicator-application/usr/lib -name \*.la -exec rm {} \;
- find debian/indicator-application/usr/lib -name \*.a -exec rm {} \;
+LDFLAGS += -Wl,-z,defs -Wl,--as-needed
common-binary-predeb-arch:: list-missing
- dh_fixperms
- dh_strip
-
-clean::
- -rm -rf $(addprefix build-, $(PY_VERSIONS))
- -rm -rf $(addprefix configure-stamp-, $(PY_VERSIONS))
- -rm -rf $(addprefix build-stamp-, $(PY_VERSIONS))
- -rm -rf $(addprefix install-stamp-, $(PY_VERSIONS))
- rm -rf $(MONO_SHARED_DIR)/.wapi