aboutsummaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorKen VanDine <ken.vandine@canonical.com>2011-06-22 13:26:15 -0400
committerKen VanDine <ken.vandine@canonical.com>2011-06-22 13:26:15 -0400
commitf2c00ec02764df9af713482b63712f1058c6d19f (patch)
tree16051d9d9e530d91a46462a5c9f743a74ddf9da6 /debian/rules
parent3315ba58c8f79fc1d1fcb50098e231aefd32a625 (diff)
downloadayatana-indicator-application-f2c00ec02764df9af713482b63712f1058c6d19f.tar.gz
ayatana-indicator-application-f2c00ec02764df9af713482b63712f1058c6d19f.tar.bz2
ayatana-indicator-application-f2c00ec02764df9af713482b63712f1058c6d19f.zip
releasing version 0.3.90-0ubuntu1
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules24
1 files changed, 15 insertions, 9 deletions
diff --git a/debian/rules b/debian/rules
index 7a7c9e8..7950ed1 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,17 +1,23 @@
#!/usr/bin/make -f
+DEB_BUILDDIR = build
+DEB_MAKE_FLAVORS = gtk2 gtk3
+
include /usr/share/cdbs/1/rules/debhelper.mk
include /usr/share/cdbs/1/class/gnome.mk
-include /usr/share/cdbs/1/rules/utils.mk
-include /usr/share/cdbs/1/rules/patchsys-quilt.mk
-LDFLAGS += -Wl,-z,defs -Wl,--as-needed
+DEB_MAKE_DESTDIRSKEL = $(CURDIR)/debian/tmp/@FLAVOR@
+DEB_DESTDIR = $(CURDIR)/debian/tmp/$(cdbs_make_curflavor)/
-common-binary-predeb-arch:: list-missing
+DEB_CONFIGURE_FLAGS_gtk2 = --with-gtk=2
+DEB_CONFIGURE_FLAGS_gtk3 = --with-gtk=3
+DEB_CONFIGURE_EXTRA_FLAGS = --disable-static
+
+LDFLAGS += -Wl,-z,defs -Wl,--as-needed
-DEB_DH_MAKESHLIBS_ARGS = -Xusr/lib/indicators
+debian/stamp-autotools/gtk2: cdbs_configure_flags += $(DEB_CONFIGURE_FLAGS_gtk2)
+debian/stamp-autotools/gtk3: cdbs_configure_flags += $(DEB_CONFIGURE_FLAGS_gtk3)
-binary-install/indicator-application::
- # remove .a/.la clutter
- rm -f debian/$(cdbs_curpkg)/usr/lib/indicators/*/*.a
- rm -f debian/$(cdbs_curpkg)/usr/lib/indicators/*/*.la
+common-install-arch::
+ find debian/tmp -name \*.la -delete
+ find debian/tmp -name \*.a -delete