aboutsummaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorMike Gabriel <mike.gabriel@das-netzwerkteam.de>2022-02-17 16:42:41 +0100
committerMike Gabriel <mike.gabriel@das-netzwerkteam.de>2022-02-17 16:42:41 +0100
commit0ef4fc107ac7a9bc0ea6418076be8510eb862ecc (patch)
treed525d03275c657c9187ca126485bf4285de77dc9 /src/CMakeLists.txt
parent3bbc1d0c2b8a54a940ef78300748074f3bf8f0d7 (diff)
parentef11732b871d63d70d58e4d397d8a4c42e81ab0c (diff)
downloadayatana-indicator-application-0ef4fc107ac7a9bc0ea6418076be8510eb862ecc.tar.gz
ayatana-indicator-application-0ef4fc107ac7a9bc0ea6418076be8510eb862ecc.tar.bz2
ayatana-indicator-application-0ef4fc107ac7a9bc0ea6418076be8510eb862ecc.zip
Merge branch 'tari01-pr/cleanup-compile-flags'
Attributes GH PR #23: https://github.com/AyatanaIndicators/ayatana-indicator-application/pull/23
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt2
1 files changed, 0 insertions, 2 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 3220d0a..3918595 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -81,7 +81,6 @@ set(SOURCES
indicator-application.c
)
-set_source_files_properties(${SOURCES} PROPERTIES COMPILE_FLAGS ${COMPILE_FLAGS})
add_library("ayatana-application" SHARED ${SOURCES})
target_compile_definitions("ayatana-application" PUBLIC G_LOG_DOMAIN="Ayatana-Indicator-Application")
target_include_directories("ayatana-application" PUBLIC ${PROJECT_DEPS_INCLUDE_DIRS})
@@ -102,7 +101,6 @@ set(SOURCES
generate-id.c
)
-set_source_files_properties(${SOURCES} PROPERTIES COMPILE_FLAGS ${COMPILE_FLAGS})
add_executable("ayatana-indicator-application-service" ${SOURCES})
target_compile_definitions("ayatana-indicator-application-service" PUBLIC DATADIR="${CMAKE_INSTALL_FULL_DATADIR}/ayatana-indicator-application")
target_compile_definitions("ayatana-indicator-application-service" PUBLIC G_LOG_DOMAIN="ayatana-indicator-application-service")