aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorRobert Tari <robert@tari.in>2023-09-06 13:25:01 +0200
committerRobert Tari <robert@tari.in>2023-09-06 13:29:54 +0200
commit1d296224eb129c14c8dd28c6c6d3be13fab94e00 (patch)
tree76f0ad355fc769d6f3132caad69486b124856a21 /CMakeLists.txt
parent25889d67ef8893aaff112ff3202c2acf9d1a9049 (diff)
downloadayatana-indicator-bluetooth-1d296224eb129c14c8dd28c6c6d3be13fab94e00.tar.gz
ayatana-indicator-bluetooth-1d296224eb129c14c8dd28c6c6d3be13fab94e00.tar.bz2
ayatana-indicator-bluetooth-1d296224eb129c14c8dd28c6c6d3be13fab94e00.zip
Drop testing/coverage options
fixes https://github.com/AyatanaIndicators/ayatana-indicator-bluetooth/issues/46
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt31
1 files changed, 2 insertions, 29 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 7a23841..f3a5ada 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,5 +1,5 @@
-project(ayatana-indicator-bluetooth C CXX)
cmake_minimum_required(VERSION 3.13)
+project (ayatana-indicator-bluetooth VERSION 22.9.1 LANGUAGES C CXX)
if(CMAKE_INSTALL_PREFIX_INITIALIZED_TO_DEFAULT)
SET(CMAKE_INSTALL_PREFIX "/usr" CACHE PATH "..." FORCE)
@@ -7,21 +7,10 @@ endif(CMAKE_INSTALL_PREFIX_INITIALIZED_TO_DEFAULT)
set(CMAKE_MODULE_PATH "${CMAKE_SOURCE_DIR}/cmake" "${CMAKE_MODULE_PATH}")
-set(PACKAGE ${CMAKE_PROJECT_NAME})
-set(PROJECT_VERSION 22.9.1)
-
# Options
-option(ENABLE_TESTS "Enable all tests and checks" OFF)
-option(ENABLE_COVERAGE "Enable coverage reports (includes enabling all tests and checks)" OFF)
option(ENABLE_WERROR "Treat all build warnings as errors" OFF)
-
-if(ENABLE_COVERAGE)
- set(ENABLE_TESTS ON)
- set(CMAKE_BUILD_TYPE "Coverage")
-else()
- set(CMAKE_BUILD_TYPE "Release")
-endif()
+set (CMAKE_BUILD_TYPE "Release")
if(ENABLE_WERROR)
add_definitions("-Werror")
@@ -71,23 +60,7 @@ add_subdirectory(data)
add_subdirectory(src)
add_subdirectory(po)
-# testing & coverage
-
-if (ENABLE_TESTS)
-
- include(CTest)
- enable_testing()
-
- if (ENABLE_COVERAGE)
-
- find_package(CoverageReport)
-
- endif()
-
-endif()
-
# Display config info
message(STATUS "Install prefix: ${CMAKE_INSTALL_PREFIX}")
-message(STATUS "Unit tests: ${ENABLE_TESTS}")
message(STATUS "Build with -Werror: ${ENABLE_WERROR}")