aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorRobert Tari <robert@tari.in>2022-01-11 16:55:52 +0100
committerRobert Tari <robert@tari.in>2022-01-11 16:55:52 +0100
commita7c80f64fe4a4a4db216bcb9b117ae233ada1157 (patch)
tree8ded87c73d3705c06772a0ccae37f33467f1f2f0 /CMakeLists.txt
parent1267d39c0efb393c52b35f0abae1155ba0748367 (diff)
downloadayatana-indicator-bluetooth-a7c80f64fe4a4a4db216bcb9b117ae233ada1157.tar.gz
ayatana-indicator-bluetooth-a7c80f64fe4a4a4db216bcb9b117ae233ada1157.tar.bz2
ayatana-indicator-bluetooth-a7c80f64fe4a4a4db216bcb9b117ae233ada1157.zip
CMakeLists.txt: Clean up compilation flags
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt16
1 files changed, 7 insertions, 9 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index d07daff..b8652fb 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -24,8 +24,13 @@ else()
endif()
if(ENABLE_WERROR)
- set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Werror")
- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Werror")
+ add_definitions("-Werror")
+endif()
+
+if("${CMAKE_CXX_COMPILER_ID}" STREQUAL "Clang")
+ add_definitions("-Weverything")
+else()
+ add_definitions("-Wall")
endif()
find_package(PkgConfig REQUIRED)
@@ -57,13 +62,6 @@ find_package(GObjectIntrospection 0.9.12)
include_directories(${SOURCE_DIR})
include_directories(${SOURCE_BINARY_DIR})
-set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -std=c11")
-set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++11")
-
-add_definitions(
- -Wall
-)
-
configure_file(
"config.h.in"
"${CMAKE_CURRENT_BINARY_DIR}/config.h"