aboutsummaryrefslogtreecommitdiff
path: root/data/CMakeLists.txt
diff options
context:
space:
mode:
authorMike Gabriel <mike.gabriel@das-netzwerkteam.de>2023-09-09 13:56:12 +0200
committerMike Gabriel <mike.gabriel@das-netzwerkteam.de>2023-09-09 13:56:12 +0200
commit33d4e8174fec5b0f51560c0328bcc282a4597739 (patch)
tree98e23f78f05c8c83d8b50a3083388cab5a41c387 /data/CMakeLists.txt
parent99055f62e6874a8a56aed858ef1effc7abe2f994 (diff)
parentcfde53e29ada7a375b48d9254c26ebff0ab40cf7 (diff)
downloadayatana-indicator-bluetooth-33d4e8174fec5b0f51560c0328bcc282a4597739.tar.gz
ayatana-indicator-bluetooth-33d4e8174fec5b0f51560c0328bcc282a4597739.tar.bz2
ayatana-indicator-bluetooth-33d4e8174fec5b0f51560c0328bcc282a4597739.zip
Merge branch 'tari01-pr/fix-schema-translation'
Attributes GH PR #51: https://github.com/AyatanaIndicators/ayatana-indicator-bluetooth/pull/51
Diffstat (limited to 'data/CMakeLists.txt')
-rw-r--r--data/CMakeLists.txt12
1 files changed, 1 insertions, 11 deletions
diff --git a/data/CMakeLists.txt b/data/CMakeLists.txt
index d3eae13..49ea20c 100644
--- a/data/CMakeLists.txt
+++ b/data/CMakeLists.txt
@@ -63,14 +63,4 @@ install(
# GSettings
###########################
-set (SCHEMA_NAME "org.ayatana.indicator.bluetooth.gschema.xml")
-set (SCHEMA_FILE "${CMAKE_CURRENT_BINARY_DIR}/${SCHEMA_NAME}")
-set (SCHEMA_FILE_IN "${CMAKE_CURRENT_SOURCE_DIR}/${SCHEMA_NAME}.in")
-
-# generate the .xml file using intltool
-find_package(Intltool REQUIRED)
-set (ENV{LC_ALL} "C")
-intltool_merge_translations("${SCHEMA_FILE_IN}" "${SCHEMA_FILE}" ALL UTF8 STYLE "xml" NO_TRANSLATIONS)
-
-# let UseGSettings do the rest
-add_schema (${SCHEMA_NAME})
+add_schema ("org.ayatana.indicator.bluetooth.gschema.xml")