aboutsummaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorMichael Terry <michael.terry@canonical.com>2013-01-31 12:19:41 -0500
committerMichael Terry <michael.terry@canonical.com>2013-01-31 12:19:41 -0500
commitd2b21e0f3edf0e401d9a67b47becd7735b03e2b5 (patch)
tree527d42d9cd799117421d60909abb0f6c120bd5b4 /debian/rules
parente73d88a47b9c2862db998f6bfb2310b033fd330a (diff)
downloadayatana-indicator-bluetooth-d2b21e0f3edf0e401d9a67b47becd7735b03e2b5.tar.gz
ayatana-indicator-bluetooth-d2b21e0f3edf0e401d9a67b47becd7735b03e2b5.tar.bz2
ayatana-indicator-bluetooth-d2b21e0f3edf0e401d9a67b47becd7735b03e2b5.zip
move debian/ inline
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules14
1 files changed, 14 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..ca87700
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,14 @@
+#!/usr/bin/make -f
+
+export DPKG_GENSYMBOLS_CHECK_LEVEL=4
+
+%:
+ dh $@ --with translations,autoreconf
+
+override_dh_autoreconf:
+ NOCONFIGURE=1 dh_autoreconf ./autogen.sh
+
+override_dh_install:
+ find debian/indicator-bluetooth/usr/lib -name *.la -delete
+ find debian/indicator-bluetooth/usr/lib -name *.a -delete
+ dh_install --fail-missing