aboutsummaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorMike Gabriel <mike.gabriel@das-netzwerkteam.de>2020-10-25 23:31:54 +0100
committerMike Gabriel <mike.gabriel@das-netzwerkteam.de>2020-10-26 12:03:59 +0100
commite672e51267ff87405700cbb80807aa6a678a06a5 (patch)
tree1fbce8d79376d671010533fe5045475464b3ec64 /debian
parentd720a7987adee52f4da1d316270be5188331d6f8 (diff)
downloadayatana-indicator-bluetooth-e672e51267ff87405700cbb80807aa6a678a06a5.tar.gz
ayatana-indicator-bluetooth-e672e51267ff87405700cbb80807aa6a678a06a5.tar.bz2
ayatana-indicator-bluetooth-e672e51267ff87405700cbb80807aa6a678a06a5.zip
Port from autotools to CMake.
Diffstat (limited to 'debian')
-rw-r--r--debian/control4
-rwxr-xr-xdebian/rules15
2 files changed, 9 insertions, 10 deletions
diff --git a/debian/control b/debian/control
index a66d6fe..56c2823 100644
--- a/debian/control
+++ b/debian/control
@@ -3,9 +3,9 @@ Section: gnome
Priority: optional
Maintainer: Mike Gabriel <mike.gabriel@das-netzwerkteam.de>
Build-Depends: debhelper (>= 9.0),
- dh-autoreconf,
dh-systemd,
- gnome-common,
+ cmake,
+ cmake-extras (>= 0.10),
libglib2.0-dev (>= 2.32.0),
liburl-dispatcher1-dev | hello,
systemd [linux-any],
diff --git a/debian/rules b/debian/rules
index 542fd05..decbbae 100755
--- a/debian/rules
+++ b/debian/rules
@@ -5,15 +5,14 @@ NULL =
export DPKG_GENSYMBOLS_CHECK_LEVEL=4
%:
- dh $@ --parallel --with systemd --with autoreconf
+ dh $@ --parallel --with systemd
-override_dh_autoreconf:
- NOCONFIGURE=1 dh_autoreconf ./autogen.sh
-
-override_dh_install:
- dh_install
- find debian/ayatana-indicator-bluetooth/usr/lib -name *.la -delete
- find debian/ayatana-indicator-bluetooth/usr/lib -name *.a -delete
+override_dh_auto_configure:
+ # Debian defines CMAKE_INSTALL_LOCALSTATEDIR as /usr/var, which is wrong.
+ # So until Debian bug 719148 is fixed, do it ourselves.
+ dh_auto_configure -- -DCMAKE_INSTALL_LOCALSTATEDIR="/var" \
+ -Denable_tests=off \
+ $(NULL)
override_dh_missing:
dh_missing --fail-missing