aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorMike Gabriel <mike.gabriel@das-netzwerkteam.de>2020-10-25 23:31:54 +0100
committerMike Gabriel <mike.gabriel@das-netzwerkteam.de>2020-10-26 12:03:59 +0100
commite672e51267ff87405700cbb80807aa6a678a06a5 (patch)
tree1fbce8d79376d671010533fe5045475464b3ec64 /src/Makefile.am
parentd720a7987adee52f4da1d316270be5188331d6f8 (diff)
downloadayatana-indicator-bluetooth-e672e51267ff87405700cbb80807aa6a678a06a5.tar.gz
ayatana-indicator-bluetooth-e672e51267ff87405700cbb80807aa6a678a06a5.tar.bz2
ayatana-indicator-bluetooth-e672e51267ff87405700cbb80807aa6a678a06a5.zip
Port from autotools to CMake.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am39
1 files changed, 0 insertions, 39 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
deleted file mode 100644
index 44d6406..0000000
--- a/src/Makefile.am
+++ /dev/null
@@ -1,39 +0,0 @@
-pkglibexec_PROGRAMS = ayatana-indicator-bluetooth-service
-
-ayatana_indicator_bluetooth_service_SOURCES = \
- bluetooth.vala \
- bluez.vala \
- desktop.vala \
- device.vala \
- main.vala \
- phone.vala \
- profile.vala \
- killswitch.vala \
- service.vala
-
-ayatana_indicator_bluetooth_service_VALAFLAGS = \
- --ccode \
- --vapidir=$(top_srcdir)/vapi/ \
- --vapidir=./ \
- --pkg config \
- --pkg rfkill \
- --pkg url-dispatcher \
- --pkg posix \
- --pkg glib-2.0 \
- --pkg gio-2.0
-
-# -w to disable warnings for vala-generated code
-ayatana_indicator_bluetooth_service_CFLAGS = \
- -DGETTEXT_PACKAGE=\"$(GETTEXT_PACKAGE)\" \
- -DLOCALE_DIR=\"$(datadir)/locale\" \
- -w \
- $(URL_DISPATCHER_CFLAGS) \
- $(SERVICE_DEPS_CFLAGS)
-
-ayatana_indicator_bluetooth_service_LDADD = \
- $(URL_DISPATCHER_LIBS) \
- $(SERVICE_DEPS_LIBS)
-
-CLEANFILES = \
- $(patsubst %.vala,%.c,$(filter %.vala, $(SOURCES))) \
- *_vala.stamp