aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac73
1 files changed, 0 insertions, 73 deletions
diff --git a/configure.ac b/configure.ac
deleted file mode 100644
index c5e9aa9..0000000
--- a/configure.ac
+++ /dev/null
@@ -1,73 +0,0 @@
-AC_INIT([ayatana-indicator-bluetooth],[13.10.0])
-AM_INIT_AUTOMAKE([1.11 no-dist-gzip dist-xz foreign])
-AC_CONFIG_HEADERS([config.h])
-AM_SILENT_RULES([yes])
-AM_MAINTAINER_MODE
-
-AM_PROG_VALAC([0.16.0])
-AM_PROG_CC_C_O
-LT_INIT
-
-GLIB_GSETTINGS
-
-dnl ###########################################################################
-dnl Dependencies
-dnl ###########################################################################
-
-GLIB_REQUIRED_VERSION=2.36
-GIO_REQUIRED_VERSION=2.36
-URL_DISPATCHER_1_REQUIRED_VERSION=1
-
-PKG_CHECK_MODULES(SERVICE_DEPS, [glib-2.0 >= $GLIB_REQUIRED_VERSION
- gio-unix-2.0 >= $GIO_REQUIRED_VERSION])
-
-PKG_CHECK_EXISTS(url-dispatcher-1,
- [have_urldispatcher="yes"],
- [have_urldispatcher="no"])
-
-if test "x$have_urldispatcher" == "xyes"; then
- PKG_CHECK_MODULES(URL_DISPATCHER, [url-dispatcher-1 >= $URL_DISPATCHER_1_REQUIRED_VERSION])
-fi
-
-SYSTEMD_USERDIR=`$PKG_CONFIG --variable=systemduserunitdir systemd`
-AC_SUBST(SYSTEMD_USERDIR)
-
-dnl ##############################
-dnl # Custom Junk
-dnl ##############################
-
-AC_DEFUN([AC_DEFINE_PATH], [
- test "x$prefix" = xNONE && prefix="$ac_default_prefix"
- test "x$exec_prefix" = xNONE && exec_prefix='${prefix}'
- ac_define_path=`eval echo [$]$2`
- ac_define_path=`eval echo [$]ac_define_path`
- $1="$ac_define_path"
- AC_SUBST($1)
- ifelse($3, ,
- AC_DEFINE_UNQUOTED($1, "$ac_define_path"),
- AC_DEFINE_UNQUOTED($1, "$ac_define_path", $3))
-])
-
-dnl ###########################
-dnl # Internationalization
-dnl ###########################
-
-IT_PROG_INTLTOOL([0.41.0])
-
-GETTEXT_PACKAGE=ayatana-indicator-bluetooth
-AC_SUBST(GETTEXT_PACKAGE)
-AC_DEFINE_UNQUOTED(GETTEXT_PACKAGE, "$GETTEXT_PACKAGE", [Name of the default get text domain])
-AC_DEFINE_PATH(LOCALEDIR, "${datadir}/locale", [locale directory])
-
-AM_GLIB_GNU_GETTEXT
-
-dnl ###########################################################################
-dnl Files to generate
-dnl ###########################################################################
-
-AC_OUTPUT([
-Makefile
-data/Makefile
-po/Makefile.in
-src/Makefile
-])