aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac34
1 files changed, 34 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 0000000..d7d5b4d
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,34 @@
+AC_INIT(indicator-bluetooth, 0.0.1)
+AM_INIT_AUTOMAKE([1.11 no-dist-gzip dist-xz foreign])
+AM_SILENT_RULES([yes])
+AM_MAINTAINER_MODE
+
+AM_PROG_VALAC([0.16.0])
+AM_PROG_CC_C_O
+
+dnl ###########################################################################
+dnl Dependencies
+dnl ###########################################################################
+
+PKG_CHECK_MODULES(INDICATOR_BLUETOOTH, [
+ glib-2.0
+ gtk+-3.0
+ appindicator3-0.1
+])
+
+dnl ###########################################################################
+dnl Internationalization
+dnl ###########################################################################
+
+IT_PROG_INTLTOOL([0.35.0])
+AC_SUBST(GETTEXT_PACKAGE, indicator-bluetooth)
+
+dnl ###########################################################################
+dnl Files to generate
+dnl ###########################################################################
+
+AC_OUTPUT([
+Makefile
+po/Makefile.in
+src/Makefile
+])