aboutsummaryrefslogtreecommitdiff
path: root/data/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'data/Makefile.am')
-rw-r--r--data/Makefile.am14
1 files changed, 13 insertions, 1 deletions
diff --git a/data/Makefile.am b/data/Makefile.am
index ec60c73..9784451 100644
--- a/data/Makefile.am
+++ b/data/Makefile.am
@@ -16,6 +16,17 @@ BUILT_SOURCES += $(upstart_jobs_DATA)
EXTRA_DIST += $(upstart_jobs_in)
CLEANFILES += $(upstart_jobs_DATA)
+# the upstart version of the xdg autostart job file
+# see https://code.launchpad.net/~charlesk/indicator-bluetooth/upstart-job/+merge/198100
+upstart_xdg_autostartdir = $(datadir)/upstart/xdg/autostart
+upstart_xdg_autostart_DATA = indicator-bluetooth.desktop
+upstart_xdg_autostart_in = indicator-bluetooth.upstart.desktop.in
+$(upstart_xdg_autostart_DATA): $(upstart_xdg_autostart_in)
+ $(AM_V_GEN) $(SED) -e "s|\@pkglibexecdir\@|$(pkglibexecdir)|" $< > $@
+BUILT_SOURCES += $(upstart_xdg_autostart_DATA)
+EXTRA_DIST += $(upstart_xdg_autostart_in)
+CLEANFILES += $(upstart_xdg_autostart_DATA)
+
# the xdg autostart job file
xdg_autostartdir = /etc/xdg/autostart
xdg_autostart_DATA = indicator-bluetooth.desktop
@@ -34,7 +45,8 @@ gsettings_SCHEMAS = com.canonical.indicator.bluetooth.gschema.xml
EXTRA_DIST += \
com.canonical.indicator.bluetooth.gschema.xml.in \
indicator-bluetooth.conf.in \
- indicator-bluetooth.desktop.in
+ indicator-bluetooth.desktop.in \
+ indicator-bluetooth.upstart.desktop.in
CLEANFILES += \
$(dbus_services_DATA) \