aboutsummaryrefslogtreecommitdiff
path: root/data/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'data/Makefile.am')
-rw-r--r--data/Makefile.am36
1 files changed, 27 insertions, 9 deletions
diff --git a/data/Makefile.am b/data/Makefile.am
index fc9beee..ec60c73 100644
--- a/data/Makefile.am
+++ b/data/Makefile.am
@@ -1,23 +1,41 @@
+BUILT_SOURCES =
+EXTRA_DIST =
+CLEANFILES =
# the indicator bus file
indicatorsdir = $(datadir)/unity/indicators
dist_indicators_DATA = com.canonical.indicator.bluetooth
-# the dbus service file
-dbus_servicesdir = $(datadir)/dbus-1/services
-dbus_services_DATA = indicator-bluetooth.service
+# the upstart job file
+upstart_jobsdir = $(datadir)/upstart/sessions
+upstart_jobs_DATA = indicator-bluetooth.conf
+upstart_jobs_in = $(upstart_jobs_DATA:.conf=.conf.in)
+$(upstart_jobs_DATA): $(upstart_jobs_in)
+ $(AM_V_GEN) $(SED) -e "s|\@pkglibexecdir\@|$(pkglibexecdir)|" $< > $@
+BUILT_SOURCES += $(upstart_jobs_DATA)
+EXTRA_DIST += $(upstart_jobs_in)
+CLEANFILES += $(upstart_jobs_DATA)
-%.service: %.service.in
- sed -e "s|\@pkglibexecdir\@|$(pkglibexecdir)|" $< > $@
+# the xdg autostart job file
+xdg_autostartdir = /etc/xdg/autostart
+xdg_autostart_DATA = indicator-bluetooth.desktop
+xdg_autostart_in = $(xdg_autostart_DATA:.desktop=.desktop.in)
+$(xdg_autostart_DATA): $(xdg_autostart_in)
+ $(AM_V_GEN) $(SED) -e "s|\@pkglibexecdir\@|$(pkglibexecdir)|" $< > $@
+BUILT_SOURCES += $(xdg_autostart_DATA)
+EXTRA_DIST += $(xdg_autostart_in)
+CLEANFILES += $(xdg_autostart_DATA)
+# the gsettings schema
gsettings_SCHEMAS = com.canonical.indicator.bluetooth.gschema.xml
@INTLTOOL_XML_NOMERGE_RULE@
@GSETTINGS_RULES@
-EXTRA_DIST = \
- indicator-bluetooth.service.in \
- com.canonical.indicator.bluetooth.gschema.xml.in
+EXTRA_DIST += \
+ com.canonical.indicator.bluetooth.gschema.xml.in \
+ indicator-bluetooth.conf.in \
+ indicator-bluetooth.desktop.in
-CLEANFILES = \
+CLEANFILES += \
$(dbus_services_DATA) \
$(gsettings_SCHEMAS)