aboutsummaryrefslogtreecommitdiff
path: root/data/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'data/Makefile.am')
-rw-r--r--data/Makefile.am16
1 files changed, 3 insertions, 13 deletions
diff --git a/data/Makefile.am b/data/Makefile.am
index 9784451..81f4d5e 100644
--- a/data/Makefile.am
+++ b/data/Makefile.am
@@ -2,6 +2,8 @@ BUILT_SOURCES =
EXTRA_DIST =
CLEANFILES =
+SUBDIRS = upstart
+
# the indicator bus file
indicatorsdir = $(datadir)/unity/indicators
dist_indicators_DATA = com.canonical.indicator.bluetooth
@@ -16,17 +18,6 @@ BUILT_SOURCES += $(upstart_jobs_DATA)
EXTRA_DIST += $(upstart_jobs_in)
CLEANFILES += $(upstart_jobs_DATA)
-# the upstart version of the xdg autostart job file
-# see https://code.launchpad.net/~charlesk/indicator-bluetooth/upstart-job/+merge/198100
-upstart_xdg_autostartdir = $(datadir)/upstart/xdg/autostart
-upstart_xdg_autostart_DATA = indicator-bluetooth.desktop
-upstart_xdg_autostart_in = indicator-bluetooth.upstart.desktop.in
-$(upstart_xdg_autostart_DATA): $(upstart_xdg_autostart_in)
- $(AM_V_GEN) $(SED) -e "s|\@pkglibexecdir\@|$(pkglibexecdir)|" $< > $@
-BUILT_SOURCES += $(upstart_xdg_autostart_DATA)
-EXTRA_DIST += $(upstart_xdg_autostart_in)
-CLEANFILES += $(upstart_xdg_autostart_DATA)
-
# the xdg autostart job file
xdg_autostartdir = /etc/xdg/autostart
xdg_autostart_DATA = indicator-bluetooth.desktop
@@ -45,8 +36,7 @@ gsettings_SCHEMAS = com.canonical.indicator.bluetooth.gschema.xml
EXTRA_DIST += \
com.canonical.indicator.bluetooth.gschema.xml.in \
indicator-bluetooth.conf.in \
- indicator-bluetooth.desktop.in \
- indicator-bluetooth.upstart.desktop.in
+ indicator-bluetooth.desktop.in
CLEANFILES += \
$(dbus_services_DATA) \