aboutsummaryrefslogtreecommitdiff
path: root/data/upstart/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'data/upstart/Makefile.am')
-rw-r--r--data/upstart/Makefile.am17
1 files changed, 17 insertions, 0 deletions
diff --git a/data/upstart/Makefile.am b/data/upstart/Makefile.am
new file mode 100644
index 0000000..2012021
--- /dev/null
+++ b/data/upstart/Makefile.am
@@ -0,0 +1,17 @@
+BUILT_SOURCES =
+EXTRA_DIST =
+CLEANFILES =
+
+# the upstart version of the xdg autostart job file
+# see https://code.launchpad.net/~charlesk/indicator-bluetooth/upstart-job/+merge/198100
+upstart_xdg_autostartdir = $(datadir)/upstart/xdg/autostart
+upstart_xdg_autostart_DATA = indicator-bluetooth.desktop
+upstart_xdg_autostart_in = indicator-bluetooth.desktop.in
+$(upstart_xdg_autostart_DATA): $(upstart_xdg_autostart_in)
+ $(AM_V_GEN) $(SED) -e "s|\@pkglibexecdir\@|$(pkglibexecdir)|" $< > $@
+BUILT_SOURCES += $(upstart_xdg_autostart_DATA)
+EXTRA_DIST += $(upstart_xdg_autostart_in)
+CLEANFILES += $(upstart_xdg_autostart_DATA)
+
+EXTRA_DIST += \
+ indicator-bluetooth.upstart.desktop.in