aboutsummaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules12
1 files changed, 7 insertions, 5 deletions
diff --git a/debian/rules b/debian/rules
index decbbae..4ebd031 100755
--- a/debian/rules
+++ b/debian/rules
@@ -2,17 +2,19 @@
NULL =
+DEB_CMAKE_EXTRA_FLAGS = \
+ -DCMAKE_INSTALL_LOCALSTATEDIR="/var" \
+ -DENABLE_TESTS=ON \
+ -DENABLE_COVERAGE=OFF \
+ $(NULL)
+
export DPKG_GENSYMBOLS_CHECK_LEVEL=4
%:
dh $@ --parallel --with systemd
override_dh_auto_configure:
- # Debian defines CMAKE_INSTALL_LOCALSTATEDIR as /usr/var, which is wrong.
- # So until Debian bug 719148 is fixed, do it ourselves.
- dh_auto_configure -- -DCMAKE_INSTALL_LOCALSTATEDIR="/var" \
- -Denable_tests=off \
- $(NULL)
+ dh_auto_configure -- $(DEB_CMAKE_EXTRA_FLAGS)
override_dh_missing:
dh_missing --fail-missing