aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am34
1 files changed, 5 insertions, 29 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 2b92f9b..ed2c976 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -1,17 +1,18 @@
pkglibexec_PROGRAMS = indicator-bluetooth-service
-indicatordir = ${libdir}/indicators3/7
-indicator_LTLIBRARIES = libbluetooth.la
indicator_bluetooth_service_SOURCES = \
indicator3-0.4.vapi \
- gnome-bluetooth-1.0.vapi \
+ desktop.vala \
main.vala \
- indicator-bluetooth-service.vala
+ menu.vala \
+ phone.vala \
+ service.vala
indicator_bluetooth_service_VALAFLAGS = \
--ccode \
--vapidir=$(top_srcdir)/vapi/ \
--vapidir=./ \
+ --pkg gnome-bluetooth-1.0 \
--pkg config \
--pkg posix \
--pkg glib-2.0 \
@@ -26,31 +27,6 @@ indicator_bluetooth_service_CFLAGS = \
indicator_bluetooth_service_LDADD = \
$(INDICATOR_BLUETOOTH_SERVICE_LIBS)
-libbluetooth_la_SOURCES = \
- indicator3-0.4.vapi \
- indicator-bluetooth.vala \
- libido3-0.1.vapi
-
-libbluetooth_la_VALAFLAGS = \
- --ccode \
- --vapidir=$(top_srcdir)/vapi/ \
- --vapidir=./ \
- --pkg posix \
- --pkg glib-2.0 \
- --pkg gtk+-3.0 \
- --pkg Dbusmenu-0.4 \
- --pkg DbusmenuGtk3-0.4
-
-libbluetooth_la_CFLAGS = \
- -DGETTEXT_PACKAGE=\"$(GETTEXT_PACKAGE)\" \
- $(INDICATOR_BLUETOOTH_CFLAGS)
-
-libbluetooth_la_LIBADD = \
- $(INDICATOR_BLUETOOTH_LIBS)
-
-libbluetooth_la_LDFLAGS = \
- -module -avoid-version
-
CLEANFILES = \
$(patsubst %.vala,%.c,$(filter %.vala, $(SOURCES))) \
*_vala.stamp