aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am40
1 files changed, 32 insertions, 8 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 2dd7e41..d2ed9dd 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -1,25 +1,49 @@
-bin_PROGRAMS = indicator-bluetooth
+libexec_PROGRAMS = indicator-bluetooth-service
+indicatordir = $(INDICATORDIR)
+indicator_LTLIBRARIES = libbluetooth.la
-indicator_bluetooth_SOURCES = \
+indicator_bluetooth_service_SOURCES = \
config.vapi \
+ indicator3-0.4.vapi \
gnome-bluetooth-1.0.vapi \
- indicator-bluetooth.vala
+ indicator-bluetooth-service.vala
-indicator_bluetooth_VALAFLAGS = \
+indicator_bluetooth_service_VALAFLAGS = \
--pkg posix \
--pkg glib-2.0 \
--pkg gtk+-3.0 \
- --pkg appindicator3-0.1
+ --pkg Dbusmenu-0.4
-indicator_bluetooth_CFLAGS = \
- -DVERSION=\"$(VERSION)\" \
+indicator_bluetooth_service_CFLAGS = \
-DGETTEXT_PACKAGE=\"$(GETTEXT_PACKAGE)\" \
-DLOCALE_DIR=\"$(datadir)/locale\" \
+ $(INDICATOR_BLUETOOTH_SERVICE_CFLAGS)
+
+indicator_bluetooth_service_LDADD = \
+ $(INDICATOR_BLUETOOTH_SERVICE_LIBS)
+
+libbluetooth_la_SOURCES = \
+ config.vapi \
+ indicator3-0.4.vapi \
+ indicator-bluetooth.vala \
+ libido3-0.1.vapi
+
+libbluetooth_la_VALAFLAGS = \
+ --pkg posix \
+ --pkg glib-2.0 \
+ --pkg gtk+-3.0 \
+ --pkg Dbusmenu-0.4 \
+ --pkg DbusmenuGtk3-0.4
+
+libbluetooth_la_CFLAGS = \
$(INDICATOR_BLUETOOTH_CFLAGS)
-indicator_bluetooth_LDADD = \
+libbluetooth_la_LIBADD = \
$(INDICATOR_BLUETOOTH_LIBS)
+libbluetooth_la_LDFLAGS = \
+ -module -avoid-version
+
CLEANFILES = \
$(patsubst %.vala,%.c,$(filter %.vala, $(SOURCES))) \
*_vala.stamp