aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorRodney Dawes <rodney.dawes@canonical.com>2017-02-02 15:52:03 -0500
committerRobert Tari <robert@tari.in>2021-07-09 01:12:23 +0200
commit76789a3a3bd92c08e694b6d05020d20b49bff50f (patch)
treed77d36be2846f26e52370dcd215c90a2c7482233 /CMakeLists.txt
parent612ded78ec1762d9b71af6d5bba56eb415e1039e (diff)
downloadayatana-indicator-datetime-76789a3a3bd92c08e694b6d05020d20b49bff50f.tar.gz
ayatana-indicator-datetime-76789a3a3bd92c08e694b6d05020d20b49bff50f.tar.bz2
ayatana-indicator-datetime-76789a3a3bd92c08e694b6d05020d20b49bff50f.zip
Use cmake-extras for coverage support and always enable testing.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt10
1 files changed, 6 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 6006900..d346777 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -86,9 +86,6 @@ add_custom_target (dist
COMMAND bzr export --root=${ARCHIVE_NAME} ${CMAKE_BINARY_DIR}/${ARCHIVE_NAME}.tar.gz
WORKING_DIRECTORY ${CMAKE_SOURCE_DIR})
-add_custom_target (clean-coverage
- COMMAND find ${CMAKE_BINARY_DIR} -name '*.gcda' | xargs rm -f)
-
add_custom_target (cppcheck COMMAND cppcheck --enable=all -q --error-exitcode=2 --inline-suppr
${CMAKE_SOURCE_DIR}/src
${CMAKE_SOURCE_DIR}/tests)
@@ -118,7 +115,12 @@ if (${ENABLE_TESTS})
pkg_check_modules (DBUSTEST REQUIRED dbustest-1>=14.04.0)
enable_testing ()
if (${ENABLE_COVERAGE})
- include(GCov)
+ find_package(CoverageReport)
+ ENABLE_COVERAGE_REPORT(
+ TARGETS indicatordatetimeservice indicator-datetime-service
+ TESTS test-actions test-alarm-queue test-clock test-datetime test-exporter test-formatter test-live-actions test-locations test-menu-appointments test-menus test-notification test-notification-response test-planner test-settings test-sound test-timezone-timedated test-utils test-eds-ics-all-day-events test-eds-ics-repeating-events test-eds-ics-nonrepeating-events test-eds-ics-repeating-valarms test-eds-ics-missing-trigger test-eds-ics-tzids test-eds-ics-tzids-2 test-eds-ics-tzids-utc test-eds-ics-non-attending-alarms test-eds-ics-repeating-events-with-individual-change manual-test-snap
+ FILTER /usr/include ${CMAKE_BINARY_DIR}/*
+ )
endif ()
endif ()