aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorCharles Kerr <charles.kerr@canonical.com>2014-07-31 15:22:47 -0500
committerCharles Kerr <charles.kerr@canonical.com>2014-07-31 15:22:47 -0500
commitaf1b645de9b8116ead5ad72583f51afe28350818 (patch)
treee29afbeb9d49e0072317f41cdf6e4cadf4009a42 /CMakeLists.txt
parent0c8faf27ea83c3996c68b0ab02c0b4ed824b4129 (diff)
downloadayatana-indicator-datetime-af1b645de9b8116ead5ad72583f51afe28350818.tar.gz
ayatana-indicator-datetime-af1b645de9b8116ead5ad72583f51afe28350818.tar.bz2
ayatana-indicator-datetime-af1b645de9b8116ead5ad72583f51afe28350818.zip
drop the ubuntu-application-api middleman and call usensorsd directly: ua_sensors_haptic_new() crashes on desktop and ua_sensors_haptic_vibrate_once() makes blocking dbus calls.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 1 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 3bc7e81..9b4987e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -41,8 +41,7 @@ pkg_check_modules (SERVICE_DEPS REQUIRED
gstreamer-1.0>=1.2
libnotify>=0.7.6
url-dispatcher-1>=1
- properties-cpp>=0.0.1
- ubuntu-platform-api>=2.2.0)
+ properties-cpp>=0.0.1)
include_directories (SYSTEM ${SERVICE_DEPS_INCLUDE_DIRS})
CHECK_INCLUDE_FILE(ubuntu/hardware/alarm.h HAVE_UBUNTU_HW_ALARM_H)