aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorRodney Dawes <dobey.pwns@gmail.com>2018-10-31 21:56:05 -0400
committerRobert Tari <robert@tari.in>2021-07-09 03:36:53 +0200
commitbdf012f78b2ffd7356adcaa707b977889671c190 (patch)
treef7bebb907ff1b6a5bcb17388b28c5c77e0d50779 /CMakeLists.txt
parentd2fc9c2d86789797c93811ad4665bdd67adf9661 (diff)
downloadayatana-indicator-datetime-bdf012f78b2ffd7356adcaa707b977889671c190.tar.gz
ayatana-indicator-datetime-bdf012f78b2ffd7356adcaa707b977889671c190.tar.bz2
ayatana-indicator-datetime-bdf012f78b2ffd7356adcaa707b977889671c190.zip
Replace ual with url-dispatcher.
We don't really hneed ubuntu-app-launch here directly, as the API provided by url-dispatcher gives us a way to query what app handles the calendar URL, as the indicator is a trusted process. This removes the extra dependency and simplifies building slightly.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt13
1 files changed, 7 insertions, 6 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 7e08544..0a6c404 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -58,16 +58,17 @@ pkg_check_modules (SERVICE_DEPS REQUIRED
gstreamer-1.0>=1.2
libnotify>=0.7.6
properties-cpp>=0.0.1
- libaccounts-glib>=1.18)
+ libaccounts-glib>=1.18
+ messaging-menu>=0.8.2)
include_directories (SYSTEM ${SERVICE_DEPS_INCLUDE_DIRS})
-# lomiri-app-launch
+# lomiri-url-dispatcher
-pkg_check_modules(LOMIRIAPPLAUNCH lomiri-app-launch>=0)
-include_directories(${LOMIRIAPPLAUNCH_INCLUDE_DIRS})
+pkg_check_modules(URLDISPATCHER lomiri-url-dispatcher>=0)
+include_directories(${URLDISPATCHER_INCLUDE_DIRS})
-if(LOMIRIAPPLAUNCH_FOUND)
- add_definitions( -DHAS_LOMIRIAPPLAUNCH )
+if(URLDISPATCHER_FOUND)
+ add_definitions( -DHAS_URLDISPATCHER )
endif()
if(EXISTS "/usr/share/accountsservice/interfaces/com.ubuntu.touch.AccountsService.Sound.xml")