aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorCharles Kerr <charles.kerr@canonical.com>2012-11-06 18:28:32 -0600
committerCharles Kerr <charles.kerr@canonical.com>2012-11-06 18:28:32 -0600
commit7ebd1bec24a732a0f7069e727ff4036f6b925e99 (patch)
treea6c0d6c2b9e04ce2e93612a947f2d390045aea7e /Makefile.am
parentab006f93c2bf00a3bb7b33cebf26a12e46821fbb (diff)
downloadayatana-indicator-datetime-7ebd1bec24a732a0f7069e727ff4036f6b925e99.tar.gz
ayatana-indicator-datetime-7ebd1bec24a732a0f7069e727ff4036f6b925e99.tar.bz2
ayatana-indicator-datetime-7ebd1bec24a732a0f7069e727ff4036f6b925e99.zip
add Google Test scaffolding to indicator-datetime: autotools rules, support for finding the uninstalled copy of the gsettings schema, and a 'hello world' test.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am12
1 files changed, 7 insertions, 5 deletions
diff --git a/Makefile.am b/Makefile.am
index 224ec45..c8b7f9a 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,10 +1,12 @@
ACLOCAL_AMFLAGS = -I m4 ${ACLOCAL_FLAGS}
-SUBDIRS = \
- src \
- data \
- tests \
- po
+SUBDIRS = po data src
+
+if BUILD_TESTS
+SUBDIRS += tests
+# build src first
+tests: src
+endif
DISTCHECK_CONFIGURE_FLAGS = --enable-localinstall