aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorTed Gould <ted@gould.cx>2010-01-04 22:32:37 -0600
committerTed Gould <ted@gould.cx>2010-01-04 22:32:37 -0600
commit82381c6aeec60c8c4d8e88bd317321d10eeb0c9f (patch)
treed0c8853ce145a613b458b3c46e2174fa4f685383 /Makefile.am
downloadayatana-indicator-datetime-82381c6aeec60c8c4d8e88bd317321d10eeb0c9f.tar.gz
ayatana-indicator-datetime-82381c6aeec60c8c4d8e88bd317321d10eeb0c9f.tar.bz2
ayatana-indicator-datetime-82381c6aeec60c8c4d8e88bd317321d10eeb0c9f.zip
Boot strap
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am22
1 files changed, 22 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 0000000..a96836c
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,22 @@
+
+SUBDIRS = \
+ src \
+ data \
+ tests \
+ po
+
+DISTCHECK_CONFIGURE_FLAGS = --enable-localinstall
+
+dist-hook:
+ @if test -d "$(top_srcdir)/.bzr"; \
+ then \
+ echo Creating ChangeLog && \
+ ( cd "$(top_srcdir)" && \
+ echo '# Generated by Makefile. Do not edit.'; echo; \
+ $(top_srcdir)/missing --run bzr log --gnu-changelog ) > ChangeLog.tmp \
+ && mv -f ChangeLog.tmp $(top_distdir)/ChangeLog \
+ || (rm -f ChangeLog.tmp; \
+ echo Failed to generate ChangeLog >&2 ); \
+ else \
+ echo Failed to generate ChangeLog: not a branch >&2; \
+ fi