aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorTed Gould <ted@gould.cx>2010-12-03 13:36:33 -0600
committerTed Gould <ted@gould.cx>2010-12-03 13:36:33 -0600
commit8e1fbde30cfce799b64477113b404d5cda3306aa (patch)
treecbd19c9bc5ff7638b2aabe9e81028cdd87fb4a79 /Makefile.am
parent83b6ed9560abbeebeae87c8bc5f81955d6c0799c (diff)
parent803f8f9c0a81d34c9d94c7b27e3b78fb0a6ecab3 (diff)
downloadayatana-indicator-datetime-8e1fbde30cfce799b64477113b404d5cda3306aa.tar.gz
ayatana-indicator-datetime-8e1fbde30cfce799b64477113b404d5cda3306aa.tar.bz2
ayatana-indicator-datetime-8e1fbde30cfce799b64477113b404d5cda3306aa.zip
Import upstream version 0.1.90
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am12
1 files changed, 12 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 4b2bca4..a692889 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -22,3 +22,15 @@ dist-hook:
else \
echo Failed to generate ChangeLog: not a branch >&2; \
fi
+ @if test -d "$(top_srcdir)/.bzr"; \
+ then \
+ echo Creating AUTHORS && \
+ ( cd "$(top_srcdir)" && \
+ echo '# Generated by Makefile. Do not edit.'; echo; \
+ $(top_srcdir)/missing --run bzr log --long --levels=0 | grep -e "^\s*author:" -e "^\s*committer:" | cut -d ":" -f 2 | cut -d "<" -f 1 | sort -u) > AUTHORS.tmp \
+ && mv -f AUTHORS.tmp $(top_distdir)/AUTHORS \
+ || (rm -f AUTHORS.tmp; \
+ echo Failed to generate AUTHORS >&2 ); \
+ else \
+ echo Failed to generate AUTHORS: not a branch >&2; \
+ fi