aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorKen VanDine <ken.vandine@canonical.com>2010-12-07 15:15:51 -0500
committerKen VanDine <ken.vandine@canonical.com>2010-12-07 15:15:51 -0500
commit9ea1956cb52c8a3c7915a4d8b3e0b1e022d57584 (patch)
tree5afee97cd7cb6fb56d77b72b8d552cb6d5664284 /Makefile.am
parent974563dd39779e15266247310a65a24e96eeee6d (diff)
parent04f95aabad5e8ca3e9503d696aa894d03b036de2 (diff)
downloadayatana-indicator-datetime-9ea1956cb52c8a3c7915a4d8b3e0b1e022d57584.tar.gz
ayatana-indicator-datetime-9ea1956cb52c8a3c7915a4d8b3e0b1e022d57584.tar.bz2
ayatana-indicator-datetime-9ea1956cb52c8a3c7915a4d8b3e0b1e022d57584.zip
releasing version 0.1.90-0ubuntu10.1.90-0ubuntu1
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am12
1 files changed, 12 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 4b2bca4..a692889 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -22,3 +22,15 @@ dist-hook:
else \
echo Failed to generate ChangeLog: not a branch >&2; \
fi
+ @if test -d "$(top_srcdir)/.bzr"; \
+ then \
+ echo Creating AUTHORS && \
+ ( cd "$(top_srcdir)" && \
+ echo '# Generated by Makefile. Do not edit.'; echo; \
+ $(top_srcdir)/missing --run bzr log --long --levels=0 | grep -e "^\s*author:" -e "^\s*committer:" | cut -d ":" -f 2 | cut -d "<" -f 1 | sort -u) > AUTHORS.tmp \
+ && mv -f AUTHORS.tmp $(top_distdir)/AUTHORS \
+ || (rm -f AUTHORS.tmp; \
+ echo Failed to generate AUTHORS >&2 ); \
+ else \
+ echo Failed to generate AUTHORS: not a branch >&2; \
+ fi