aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMichael Terry <mike@mterry.name>2011-02-18 10:50:49 -0500
committerMichael Terry <mike@mterry.name>2011-02-18 10:50:49 -0500
commit354fc2c05e901b65f4a0516473632a4df3878ed6 (patch)
tree8435864d53f4a5dee4f5a5233885b1c7af929fff /configure.ac
parenta10f207618976b59a0cc43c01befbf67128c92a5 (diff)
downloadayatana-indicator-datetime-354fc2c05e901b65f4a0516473632a4df3878ed6.tar.gz
ayatana-indicator-datetime-354fc2c05e901b65f4a0516473632a4df3878ed6.tar.bz2
ayatana-indicator-datetime-354fc2c05e901b65f4a0516473632a4df3878ed6.zip
add polkit support and use new gnome-settings-daemon ntp-setting support
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 5 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 3cf45ef..2418f12 100644
--- a/configure.ac
+++ b/configure.ac
@@ -113,15 +113,18 @@ AS_IF([test "x$with_gtk" = x3],
[AC_MSG_FAILURE([Value for --with-gtk was neither 2 nor 3])]
)
+# FIXME: polkit-gtk-1 isn't gtk3-compatible
AS_IF([test "x$with_gtk" = x3],
[PKG_CHECK_MODULES(PREF, gio-2.0 >= $GIO_REQUIRED_VERSION
gtk+-3.0 >= $GTK3_REQUIRED_VERSION
- unique-3.0)
+ unique-3.0
+ polkit-gtk-1)
],
[test "x$with_gtk" = x2],
[PKG_CHECK_MODULES(PREF, gio-2.0 >= $GIO_REQUIRED_VERSION
gtk+-2.0 >= $GTK_REQUIRED_VERSION
- unique-1.0)
+ unique-1.0
+ polkit-gtk-1)
],
[AC_MSG_FAILURE([Value for --with-gtk was neither 2 nor 3])]
)