aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMichael Terry <mike@mterry.name>2011-02-22 11:20:34 -0500
committerMichael Terry <mike@mterry.name>2011-02-22 11:20:34 -0500
commit45b1165f77cab0ac8dc40ce7d605e32c697fb22d (patch)
treeb803709c23f3e50dbca5b57ebb3a4215b0b45d58 /configure.ac
parent8754d980f2992a2596465d46b5d18d35846060fa (diff)
downloadayatana-indicator-datetime-45b1165f77cab0ac8dc40ce7d605e32c697fb22d.tar.gz
ayatana-indicator-datetime-45b1165f77cab0ac8dc40ce7d605e32c697fb22d.tar.bz2
ayatana-indicator-datetime-45b1165f77cab0ac8dc40ce7d605e32c697fb22d.zip
add initial timezone map implementation, borrowed from gnome-control-center
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 16 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 242033e..bcedddc 100644
--- a/configure.ac
+++ b/configure.ac
@@ -135,6 +135,17 @@ AS_IF([test "x$with_gtk" = x3],
],
[AC_MSG_FAILURE([Value for --with-gtk was neither 2 nor 3])]
)
+
+AS_IF([test "x$with_gtk" = x3],
+ [PKG_CHECK_MODULES(LIBMAP, gio-2.0 >= $GIO_REQUIRED_VERSION
+ gtk+-3.0 >= $GTK3_REQUIRED_VERSION)
+ ],
+ [test "x$with_gtk" = x2],
+ [PKG_CHECK_MODULES(LIBMAP, gio-2.0 >= $GIO_REQUIRED_VERSION
+ gtk+-2.0 >= $GTK_REQUIRED_VERSION)
+ ],
+ [AC_MSG_FAILURE([Value for --with-gtk was neither 2 nor 3])]
+)
AC_SUBST(INDICATOR_CFLAGS)
AC_SUBST(INDICATOR_LIBS)
@@ -144,6 +155,10 @@ AC_SUBST(SERVICE_LIBS)
AC_SUBST(PREF_CFLAGS)
AC_SUBST(PREF_LIBS)
+AC_SUBST(LIBMAP_CFLAGS)
+AC_SUBST(LIBMAP_LIBS)
+AC_SUBST(LIBMAP_LDFLAGS)
+
###########################
# Grab the GSettings Macros
###########################
@@ -223,6 +238,7 @@ AM_GLIB_GNU_GETTEXT
AC_OUTPUT([
Makefile
+libmap/Makefile
src/Makefile
data/Makefile
tests/Makefile