aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJavier Jardón <javier.jardon@codethink.co.uk>2011-09-05 14:31:13 +0100
committerJavier Jardón <javier.jardon@codethink.co.uk>2011-09-05 14:31:13 +0100
commit805b0b286192282b590b4003612fdf29d2284c0a (patch)
tree982633170d41ad9e514d8482610003d352e83704 /configure.ac
parentb9e51f0108e43b19527011be762b227498b1b0c6 (diff)
downloadayatana-indicator-datetime-805b0b286192282b590b4003612fdf29d2284c0a.tar.gz
ayatana-indicator-datetime-805b0b286192282b590b4003612fdf29d2284c0a.tar.bz2
ayatana-indicator-datetime-805b0b286192282b590b4003612fdf29d2284c0a.zip
indicator-datetime.c: Use GnomeWallClock instead of periodic timeout
This class support changes in the timezone and notifications of clock skews when using a recent version of Linux (using timerfds) See https://bugzilla.gnome.org/show_bug.cgi?id=655129 Fixes https://bugs.launchpad.net/indicator-datetime/+bug/837440
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 7b8682c..55c4f3b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -26,6 +26,7 @@ AC_HEADER_STDC
LT_PREREQ([2.2])
LT_INIT([disable-static])
+AC_CHECK_LIB([m],[pow])
AC_ARG_ENABLE([deprecations],
[AS_HELP_STRING([--enable-deprecations],
@@ -74,6 +75,7 @@ GCONF_REQUIRED_VERSION=2.31
AS_IF([test "x$with_gtk" = x3],
[PKG_CHECK_MODULES(INDICATOR, indicator3-0.4 >= $INDICATOR_REQUIRED_VERSION
glib-2.0 >= $GLIB_REQUIRED_VERSION
+ gnome-desktop-3.0 >= $GNOME_DESKTOP_REQUIRED_VERSION
dbusmenu-glib-0.4 >= $DBUSMENUGLIB_REQUIRED_VERSION
dbusmenu-gtk3-0.4 >= $DBUSMENUGTK_REQUIRED_VERSION
libido3-0.1 >= $INDICATOR_DISPLAY_OBJECTS)