aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorCharles Kerr <charles.kerr@canonical.com>2012-02-15 16:31:31 -0600
committerCharles Kerr <charles.kerr@canonical.com>2012-02-15 16:31:31 -0600
commitb18a7b815228aa5fdbfee6272fdcc621becbf3b8 (patch)
treea0ac50094bd2e0c2d408e5828ea85b8ed7e09b81 /configure.ac
parented432b431805543fd27b991aeab7908fabe74ae0 (diff)
parent78e082682d5d833fd271899b67d6a203acffa803 (diff)
downloadayatana-indicator-datetime-b18a7b815228aa5fdbfee6272fdcc621becbf3b8.tar.gz
ayatana-indicator-datetime-b18a7b815228aa5fdbfee6272fdcc621becbf3b8.tar.bz2
ayatana-indicator-datetime-b18a7b815228aa5fdbfee6272fdcc621becbf3b8.zip
lp:~ballogy/indicator-datetime/make-ccpanel-optional
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac53
1 files changed, 40 insertions, 13 deletions
diff --git a/configure.ac b/configure.ac
index b563ce8..6931c2e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -103,11 +103,35 @@ PKG_CHECK_MODULES(SERVICE, indicator3-0.4 >= $INDICATOR_REQUIRED_VERSION
gdk-3.0 >= GDK_REQUIRED_VERSION
gconf-2.0 >= GCONF_REQUIRED_VERSION)
-PKG_CHECK_MODULES(PREF, gio-2.0 >= $GIO_REQUIRED_VERSION
- gtk+-3.0 >= $GTK3_REQUIRED_VERSION
- timezonemap
- libgnome-control-center
- polkit-gobject-1)
+###########################
+# Control Center panel
+###########################
+
+AC_ARG_WITH([ccpanel],
+ AS_HELP_STRING([--with-ccpanel], [enable Control Center panel]),,
+ with_ccpanel=auto)
+
+if test x"$with_ccpanel" != x"no" ; then
+ PKG_CHECK_MODULES([PREF],
+ [gio-2.0 >= $GIO_REQUIRED_VERSION
+ gtk+-3.0 >= $GTK3_REQUIRED_VERSION
+ timezonemap
+ libgnome-control-center
+ polkit-gobject-1],
+ [have_ccpanel=yes],
+ [have_ccpanel=no])
+ if test x${have_ccpanel} = xyes; then
+ AC_DEFINE(HAVE_CCPANEL, 1, [Define to 1 to enable Control Center panel])
+ PKG_CHECK_MODULES(LIBMAP, gio-2.0 >= $GIO_REQUIRED_VERSION
+ gtk+-3.0 >= $GTK3_REQUIRED_VERSION)
+ fi
+ if test x${with_ccpanel} = xyes && test x${have_ccpanel} = xno; then
+ AC_MSG_ERROR([Control Center panel configured but not found])
+ fi
+else
+ have_ccpanel=no
+fi
+AM_CONDITIONAL(BUILD_CCPANEL, test x${have_ccpanel} = xyes)
###########################
# Grab the GSettings Macros
@@ -148,16 +172,18 @@ AC_SUBST(INDICATORICONSDIR)
# Control Center Info
###########################
-AS_IF([test "x$with_localinstall" = "xyes"],
- [
- CCPANELDIR="${libdir}/control-center-1/panels/"
- ],
+AS_IF([test "x$have_ccpanel" = "xyes"],
[
- CCPANELDIR=`$PKG_CONFIG --variable=extensiondir libgnome-control-center`
- ])
-
-AC_SUBST(CCPANELDIR)
+ AS_IF([test "x$with_localinstall" = "xyes"],
+ [
+ CCPANELDIR="${libdir}/control-center-1/panels/"
+ ],
+ [
+ CCPANELDIR=`$PKG_CONFIG --variable=extensiondir libgnome-control-center`
+ ])
+ AC_SUBST(CCPANELDIR)
+ ])
###########################
# DBus Service Info
###########################
@@ -220,5 +246,6 @@ Date and Time Indicator Configuration:
Prefix: $prefix
Indicator Dir: $INDICATORDIR
+ CC Panel: $have_ccpanel
CC Panel Dir: $CCPANELDIR
])