aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTed Gould <ted@gould.cx>2011-07-07 16:17:58 -0500
committerTed Gould <ted@gould.cx>2011-07-07 16:17:58 -0500
commitb64854473ee9226bc11f5b27b0057fab82a2f098 (patch)
treea64aabc5e071d3d04671fca285b13356b2c345fd /configure.ac
parent62a1ba2b91d2e916c9bfc99eda0793f67af6e820 (diff)
parent5d36567ca57ebd73e7a759c83542d19b2aa8814d (diff)
downloadayatana-indicator-datetime-b64854473ee9226bc11f5b27b0057fab82a2f098.tar.gz
ayatana-indicator-datetime-b64854473ee9226bc11f5b27b0057fab82a2f098.tar.bz2
ayatana-indicator-datetime-b64854473ee9226bc11f5b27b0057fab82a2f098.zip
Making the preferences a gnome-control-center plugin instead of a stand alone app
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 16 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 31de25e..0342b96 100644
--- a/configure.ac
+++ b/configure.ac
@@ -102,6 +102,7 @@ PKG_CHECK_MODULES(PREF, gio-2.0 >= $GIO_REQUIRED_VERSION
gtk+-3.0 >= $GTK3_REQUIRED_VERSION
unique-3.0
json-glib-1.0
+ libgnome-control-center
polkit-gobject-1)
PKG_CHECK_MODULES(LIBMAP, gio-2.0 >= $GIO_REQUIRED_VERSION
@@ -156,6 +157,20 @@ AC_SUBST(INDICATORDIR)
AC_SUBST(INDICATORICONSDIR)
###########################
+# Control Center Info
+###########################
+
+AS_IF([test "x$with_localinstall" = "xyes"],
+ [
+ CCPANELDIR="${libdir}/control-center-1/panels/"
+ ],
+ [
+ CCPANELDIR=`$PKG_CONFIG --variable=extensiondir libgnome-control-center`
+ ])
+
+AC_SUBST(CCPANELDIR)
+
+###########################
# DBus Service Info
###########################
@@ -216,4 +231,5 @@ Date and Time Indicator Configuration:
Prefix: $prefix
Indicator Dir: $INDICATORDIR
+ CC Panel Dir: $CCPANELDIR
])