aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTed Gould <ted@gould.cx>2010-07-19 07:48:13 -0500
committerTed Gould <ted@gould.cx>2010-07-19 07:48:13 -0500
commitb93453548ac650dd5cf12785e231cfaf5e271c1e (patch)
tree5ac836c2357d65dec63c7b2dcb16d0af7f36e030 /configure.ac
parentb695b5591a84f8bf6f55cd085f7dba59012d525b (diff)
parente4a111094e82dec901da137273d79e2f1945d0ca (diff)
downloadayatana-indicator-datetime-b93453548ac650dd5cf12785e231cfaf5e271c1e.tar.gz
ayatana-indicator-datetime-b93453548ac650dd5cf12785e231cfaf5e271c1e.tar.bz2
ayatana-indicator-datetime-b93453548ac650dd5cf12785e231cfaf5e271c1e.zip
Making the timeformat configurable via translations and gsettings.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 9 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index fdc85c2..f8997bf 100644
--- a/configure.ac
+++ b/configure.ac
@@ -35,15 +35,23 @@ PKG_PROG_PKG_CONFIG
INDICATOR_REQUIRED_VERSION=0.3.0
DBUSMENUGLIB_REQUIRED_VERSION=0.1.1
DBUSMENUGTK_REQUIRED_VERSION=0.1.1
+GIO_REQUIRED_VERSION=2.25.0
PKG_CHECK_MODULES(INDICATOR, indicator >= $INDICATOR_REQUIRED_VERSION
dbusmenu-glib >= $DBUSMENUGLIB_REQUIRED_VERSION
- dbusmenu-gtk >= $DBUSMENUGTK_REQUIRED_VERSION)
+ dbusmenu-gtk >= $DBUSMENUGTK_REQUIRED_VERSION
+ gio-2.0 >= $GIO_REQUIRED_VERSION)
AC_SUBST(INDICATOR_CFLAGS)
AC_SUBST(INDICATOR_LIBS)
###########################
+# Grab the GSettings Macros
+###########################
+
+GLIB_GSETTINGS
+
+###########################
# Check to see if we're local
###########################