aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTed Gould <ted@gould.cx>2011-01-14 00:19:05 -0600
committerTed Gould <ted@gould.cx>2011-01-14 00:19:05 -0600
commitcd14524ec56a149b9c9c9fa780698ea42738cb61 (patch)
tree021013ea99b62d1555df9601c9d0e74b0c29130c /configure.ac
parentb96ba2ae5062ee1f8323a3b80518e75902b91a26 (diff)
parenta30b2caf552925bdb66378f8a785385a1ee00f2a (diff)
downloadayatana-indicator-datetime-cd14524ec56a149b9c9c9fa780698ea42738cb61.tar.gz
ayatana-indicator-datetime-cd14524ec56a149b9c9c9fa780698ea42738cb61.tar.bz2
ayatana-indicator-datetime-cd14524ec56a149b9c9c9fa780698ea42738cb61.zip
Switching over to dbusmenu 0.4 and GDBus
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 5 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index dc0448c..a57d91e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -62,21 +62,21 @@ OOBS_REQUIRED_VERSION=2.31.0
AS_IF([test "x$with_gtk" = x3],
[PKG_CHECK_MODULES(INDICATOR, indicator3 >= $INDICATOR_REQUIRED_VERSION
- dbusmenu-glib >= $DBUSMENUGLIB_REQUIRED_VERSION
- dbusmenu-gtk3 >= $DBUSMENUGTK_REQUIRED_VERSION
+ dbusmenu-glib-0.4 >= $DBUSMENUGLIB_REQUIRED_VERSION
+ dbusmenu-gtk3-0.4 >= $DBUSMENUGTK_REQUIRED_VERSION
libido3-0.1 >= $INDICATOR_DISPLAY_OBJECTS)
],
[test "x$with_gtk" = x2],
[PKG_CHECK_MODULES(INDICATOR, indicator >= $INDICATOR_REQUIRED_VERSION
- dbusmenu-glib >= $DBUSMENUGLIB_REQUIRED_VERSION
- dbusmenu-gtk >= $DBUSMENUGTK_REQUIRED_VERSION
+ dbusmenu-glib-0.4 >= $DBUSMENUGLIB_REQUIRED_VERSION
+ dbusmenu-gtk-0.4 >= $DBUSMENUGTK_REQUIRED_VERSION
libido-0.1 >= $INDICATOR_DISPLAY_OBJECTS)
],
[AC_MSG_FAILURE([Value for --with-gtk was neither 2 nor 3])]
)
PKG_CHECK_MODULES(SERVICE, indicator >= $INDICATOR_REQUIRED_VERSION
- dbusmenu-glib >= $DBUSMENUGLIB_REQUIRED_VERSION
+ dbusmenu-glib-0.4 >= $DBUSMENUGLIB_REQUIRED_VERSION
libido-0.1 >= $INDICATOR_DISPLAY_OBJECTS
gio-2.0 >= $GIO_REQUIRED_VERSION
geoclue >= $GEOCLUE_REQUIRED_VERSION