aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJavier Jardón <javier.jardon@codethink.co.uk>2011-09-05 12:34:31 +0100
committerJavier Jardón <javier.jardon@codethink.co.uk>2011-09-05 12:34:31 +0100
commite4fed0186ac63ebf14a5d35b6f1aacfc306ad1ef (patch)
tree70d6da2f6988a7af0bcefb1aecfa3bebb2bfc00d /configure.ac
parent1ab5a36d28ea2d3bac39534de9c18a95bfcb0670 (diff)
downloadayatana-indicator-datetime-e4fed0186ac63ebf14a5d35b6f1aacfc306ad1ef.tar.gz
ayatana-indicator-datetime-e4fed0186ac63ebf14a5d35b6f1aacfc306ad1ef.tar.bz2
ayatana-indicator-datetime-e4fed0186ac63ebf14a5d35b6f1aacfc306ad1ef.zip
Use GnomeWallClock instead of periodic timeout
This class support changes in the timezone and notifications of clock skews when using a recent version of Linux (using timerfds) See https://bugzilla.gnome.org/show_bug.cgi?id=655129 Fixes https://bugs.launchpad.net/indicator-datetime/+bug/837440
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 71fd0e9..7c7317f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -64,6 +64,7 @@ GEOCLUE_REQUIRED_VERSION=0.12.0
ECAL_REQUIRED_VERSION=2.30
EDS_REQUIRED_VERSION=2.30
ICAL_REQUIRED_VERSION=0.44
+GNOME_DESKTOP_REQUIRED_VERSION=3.1.90
CAIRO_REQUIRED_VERSION=1.10
GDK_REQUIRED_VERSION=2.22
GLIB_REQUIRED_VERSION=2.26
@@ -100,6 +101,7 @@ PKG_CHECK_MODULES(SERVICE, indicator3-0.4 >= $INDICATOR_REQUIRED_VERSION
libedataserverui-3.0 >= EDS_REQUIRED_VERSION
cairo >= CAIRO_REQUIRED_VERSION
gdk-3.0 >= GDK_REQUIRED_VERSION
+ gnome-desktop-3.0 >= $GNOME_DESKTOP_REQUIRED_VERSION
gconf-2.0 >= GCONF_REQUIRED_VERSION)
PKG_CHECK_MODULES(PREF, gio-2.0 >= $GIO_REQUIRED_VERSION