aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTed Gould <ted@gould.cx>2010-07-12 20:58:24 -0500
committerTed Gould <ted@gould.cx>2010-07-12 20:58:24 -0500
commitfe6129a2aec01220da2e413a9141980bbd827ae8 (patch)
tree2a45dccba3d7fcc3851e3641e85bd111b16535f0 /configure.ac
parentd051dbe509a1e88a0c3047a19c94130d58a9aa94 (diff)
parenta994c55bc39f419ce752d02a60bc01d5659aad62 (diff)
downloadayatana-indicator-datetime-fe6129a2aec01220da2e413a9141980bbd827ae8.tar.gz
ayatana-indicator-datetime-fe6129a2aec01220da2e413a9141980bbd827ae8.tar.bz2
ayatana-indicator-datetime-fe6129a2aec01220da2e413a9141980bbd827ae8.zip
* Merge upstream
* Adding in GSettings for configuring the format on the panel.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 9 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 9bf0a3c..460aadc 100644
--- a/configure.ac
+++ b/configure.ac
@@ -35,15 +35,23 @@ PKG_PROG_PKG_CONFIG
INDICATOR_REQUIRED_VERSION=0.3.0
DBUSMENUGLIB_REQUIRED_VERSION=0.1.1
DBUSMENUGTK_REQUIRED_VERSION=0.1.1
+GIO_REQUIRED_VERSION=2.25.0
PKG_CHECK_MODULES(INDICATOR, indicator >= $INDICATOR_REQUIRED_VERSION
dbusmenu-glib >= $DBUSMENUGLIB_REQUIRED_VERSION
- dbusmenu-gtk >= $DBUSMENUGTK_REQUIRED_VERSION)
+ dbusmenu-gtk >= $DBUSMENUGTK_REQUIRED_VERSION
+ gio-2.0 >= $GIO_REQUIRED_VERSION)
AC_SUBST(INDICATOR_CFLAGS)
AC_SUBST(INDICATOR_LIBS)
###########################
+# Grab the GSettings Macros
+###########################
+
+GLIB_GSETTINGS
+
+###########################
# Check to see if we're local
###########################