aboutsummaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorSebastien Bacher <seb128@ubuntu.com>2012-02-20 19:40:49 +0100
committerSebastien Bacher <seb128@ubuntu.com>2012-02-20 19:40:49 +0100
commit39bc08ed8c8c3d1be351c2642c8e2eb572a3061c (patch)
treee3fc866a6652806755760ba51dd31812299a6478 /debian
parent4a2175798e434a4e33def2f30e15b49714eab33b (diff)
parentade1e121d41dd07ccc81a641862d81798e38b145 (diff)
downloadayatana-indicator-datetime-39bc08ed8c8c3d1be351c2642c8e2eb572a3061c.tar.gz
ayatana-indicator-datetime-39bc08ed8c8c3d1be351c2642c8e2eb572a3061c.tar.bz2
ayatana-indicator-datetime-39bc08ed8c8c3d1be351c2642c8e2eb572a3061c.zip
releasing version 0.3.90-0ubuntu1
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog18
-rw-r--r--debian/control9
-rw-r--r--debian/patches/disable_Werror.patch31
-rw-r--r--debian/patches/gtk_box_api.patch41
-rw-r--r--debian/patches/lp_802384.patch18
-rw-r--r--debian/patches/lp_844741.patch12
-rw-r--r--debian/patches/series4
7 files changed, 23 insertions, 110 deletions
diff --git a/debian/changelog b/debian/changelog
index f8aab12..d71eb4f 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,21 @@
+indicator-datetime (0.3.90-0ubuntu1) precise; urgency=low
+
+ * New upstream release.
+ * Still need to distribute these files even if we're not building it
+ * Adding some extra ignore stuff in
+ * Adding in code coverage calculation
+ * Allow ccpanel to be optional
+ * Move to use libtimezone map
+ * Add a name hint on the indicator
+ * Build fixes for updated dependencies
+ * Fixing Geoclue support
+ * debian/control:
+ * Bumping libdbusmenu requirement to 0.5.90
+ * Added dependency on libtimezonemap
+ * debian/patches: Removed, all upstream.
+
+ -- Ted Gould <ted@ubuntu.com> Fri, 17 Feb 2012 16:24:51 -0600
+
indicator-datetime (0.3.1-0ubuntu5) precise; urgency=low
* no change rebuild for libindicator7
diff --git a/debian/control b/debian/control
index 3167f9e..4aba64a 100644
--- a/debian/control
+++ b/debian/control
@@ -8,9 +8,9 @@ Build-Depends: cdbs,
intltool (>= 0.35.0),
libindicator-dev (>= 0.3.90),
libindicator3-dev (>= 0.3.90),
- libdbusmenu-glib-dev (>= 0.3.90),
- libdbusmenu-gtk-dev (>= 0.3.94),
- libdbusmenu-gtk3-dev (>= 0.3.94),
+ libdbusmenu-glib-dev (>= 0.5.90),
+ libdbusmenu-gtk-dev (>= 0.5.90),
+ libdbusmenu-gtk3-dev (>= 0.5.90),
libglib2.0-dev (>= 2.29.19),
libido-0.1-dev (>= 0.2.2),
libido3-0.1-dev (>= 0.2.90),
@@ -26,7 +26,8 @@ Build-Depends: cdbs,
libedataserverui-3.0-dev,
libgconf2-dev (>= 2.31),
libgnome-control-center-dev,
- dh-autoreconf
+ dh-autoreconf,
+ libtimezonemap1-dev
Standards-Version: 3.9.2
Homepage: https://launchpad.net/indicator-datetime
Vcs-Bzr: http://bazaar.launchpad.net/~ubuntu-desktop/indicator-datetime/ubuntu
diff --git a/debian/patches/disable_Werror.patch b/debian/patches/disable_Werror.patch
deleted file mode 100644
index fc267ca..0000000
--- a/debian/patches/disable_Werror.patch
+++ /dev/null
@@ -1,31 +0,0 @@
-Description: Disable -Werror, causes build failures due to deprecated symbols.
-Author: Martin Pitt <martin.pitt@ubuntu.com>
-
-Index: indicator-datetime/src/Makefile.am
-===================================================================
---- indicator-datetime.orig/src/Makefile.am 2011-10-06 06:50:07.814203000 +0200
-+++ indicator-datetime/src/Makefile.am 2012-01-23 13:04:31.541545936 +0100
-@@ -15,7 +15,6 @@
- settings-shared.h
- indicator_datetime_service_CFLAGS = \
- -Wall \
-- -Werror \
- $(SERVICE_CFLAGS) \
- -DTIMEZONE_FILE="\"/etc/timezone\"" \
- -DG_LOG_DOMAIN=\"Indicator-Datetime\"
-@@ -33,7 +32,6 @@
- indicator-datetime.c
- libdatetime_la_CFLAGS = \
- $(INDICATOR_CFLAGS) \
-- -Wall -Werror \
- -DTIMEZONE_FILE="\"/etc/timezone\"" \
- -DG_LOG_DOMAIN=\"Indicator-Datetime\"
- libdatetime_la_LIBADD = \
-@@ -53,7 +51,6 @@
- settings-shared.h
- libindicator_datetime_la_CFLAGS = \
- -Wall \
-- -Werror \
- -I$(top_srcdir)/libmap \
- $(PREF_CFLAGS) \
- -DTIMEZONE_FILE="\"/etc/timezone\"" \
diff --git a/debian/patches/gtk_box_api.patch b/debian/patches/gtk_box_api.patch
deleted file mode 100644
index 0dd28f0..0000000
--- a/debian/patches/gtk_box_api.patch
+++ /dev/null
@@ -1,41 +0,0 @@
-From: Mathieu Trudel-Lapierre <mathieu.trudel-lapierre@canonical.com>
-Subject: Port to the new gtk_box_new() instead of gtk_hbox_new().
-
-Index: indicator-datetime/src/indicator-datetime.c
-===================================================================
---- indicator-datetime.orig/src/indicator-datetime.c 2012-01-12 23:59:50.815675283 +0100
-+++ indicator-datetime/src/indicator-datetime.c 2012-01-13 00:02:24.083668449 +0100
-@@ -34,6 +34,7 @@
- #include <glib-object.h>
- #include <glib/gi18n-lib.h>
- #include <gio/gio.h>
-+#include <gtk/gtk.h>
-
- /* Indicator Stuff */
- #include <libindicator/indicator.h>
-@@ -1261,7 +1262,12 @@
-
- mi_data->gmi = gtk_menu_item_new();
-
-+#if GTK_CHECK_VERSION(3, 2, 0)
-+ GtkWidget * hbox = gtk_box_new(GTK_ORIENTATION_HORIZONTAL, 4);
-+ gtk_box_set_homogeneous (GTK_BOX(hbox), FALSE);
-+#else
- GtkWidget * hbox = gtk_hbox_new(FALSE, 4);
-+#endif
-
- /* Icon, probably someone's face or avatar on an IM */
- mi_data->icon = gtk_image_new();
-@@ -1472,7 +1478,12 @@
- gtk_check_menu_item_set_active(GTK_CHECK_MENU_ITEM(mi_data->gmi),
- dbusmenu_menuitem_property_get_bool(newitem, TIMEZONE_MENUITEM_PROP_RADIO));
-
-+#if GTK_CHECK_VERSION(3, 2, 0)
-+ GtkWidget * hbox = gtk_box_new(GTK_ORIENTATION_HORIZONTAL, 4);
-+ gtk_box_set_homogeneous (GTK_BOX(hbox), FALSE);
-+#else
- GtkWidget * hbox = gtk_hbox_new(FALSE, 4);
-+#endif
-
- /* Label, probably a username, chat room or mailbox name */
- mi_data->label = gtk_label_new("");
diff --git a/debian/patches/lp_802384.patch b/debian/patches/lp_802384.patch
deleted file mode 100644
index 2c30c9f..0000000
--- a/debian/patches/lp_802384.patch
+++ /dev/null
@@ -1,18 +0,0 @@
-=== modified file 'src/datetime-service.c'
---- a/src/datetime-service.c 2011-10-13 04:30:40 +0000
-+++ b/src/datetime-service.c 2011-10-23 21:54:15 +0000
-@@ -1404,7 +1404,12 @@
-
- geo_master = client;
-
-- if (geo_master != NULL) {
-+ if (error != NULL) {
-+ g_warning("Unable to get a GeoClue client! '%s' Geolocation based timezone support will not be available.", error->message);
-+ return;
-+ }
-+
-+ if (geo_master == NULL) {
- g_warning(_("Unable to get a GeoClue client! Geolocation based timezone support will not be available."));
- return;
- }
-
diff --git a/debian/patches/lp_844741.patch b/debian/patches/lp_844741.patch
deleted file mode 100644
index 459779d..0000000
--- a/debian/patches/lp_844741.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-=== modified file 'src/timezone-completion.c'
---- a/src/timezone-completion.c 2011-09-06 12:47:37 +0000
-+++ b/src/timezone-completion.c 2011-10-05 15:47:06 +0000
-@@ -355,7 +355,6 @@
- gchar * locale = get_locale ();
- gchar * url = g_strdup_printf (GEONAME_URL, escaped, version, locale);
- g_free (locale);
-- g_free (version);
- g_free (escaped);
-
- GFile * file = g_file_new_for_uri (url);
-
diff --git a/debian/patches/series b/debian/patches/series
deleted file mode 100644
index ab309a3..0000000
--- a/debian/patches/series
+++ /dev/null
@@ -1,4 +0,0 @@
-disable_Werror.patch
-lp_844741.patch
-lp_802384.patch
-gtk_box_api.patch