aboutsummaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorCharles Kerr <charles.kerr@canonical.com>2014-06-25 10:02:10 -0500
committerCharles Kerr <charles.kerr@canonical.com>2014-06-25 10:02:10 -0500
commit6c63582cddf7f9aea296aef3bcfebe4bcf8c6fbe (patch)
treec88ffb11c500043be4cf48c33318678efe36d818 /debian
parentf6778e1cc3e3881225e967c94de4685c732755db (diff)
downloadayatana-indicator-datetime-6c63582cddf7f9aea296aef3bcfebe4bcf8c6fbe.tar.gz
ayatana-indicator-datetime-6c63582cddf7f9aea296aef3bcfebe4bcf8c6fbe.tar.bz2
ayatana-indicator-datetime-6c63582cddf7f9aea296aef3bcfebe4bcf8c6fbe.zip
make g++ 4.9 explicit
Diffstat (limited to 'debian')
-rw-r--r--debian/control6
-rwxr-xr-xdebian/rules5
2 files changed, 10 insertions, 1 deletions
diff --git a/debian/control b/debian/control
index 5f45bea..6e379ad 100644
--- a/debian/control
+++ b/debian/control
@@ -2,8 +2,12 @@ Source: indicator-datetime
Section: misc
Priority: optional
Maintainer: Ubuntu Desktop Team <ubuntu-desktop@lists.ubuntu.com>
-# language-pack-en-base is for the unit tests s.t. we can test in 12h and 24h locales
+
+# g++-4.9: since we use c++11 features, explicitly select a g++ version
+# to protect from ABI breaks in libstdc++
+# language-pack-en-base: needed so unit tests can use 12h and 24h locales
Build-Depends: cmake,
+ g++-4.9,
dbus,
dbus-test-runner,
python3-dbusmock,
diff --git a/debian/rules b/debian/rules
index d2889aa..cf940f5 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,5 +1,10 @@
#!/usr/bin/make -f
+# Explicitly selecting a G{CC,++}-version here to avoid accidental
+# ABI breaks introduced by toolchain updates.
+export CC=$(DEB_HOST_GNU_TYPE)-gcc-4.9
+export CXX=$(DEB_HOST_GNU_TYPE)-g++-4.9
+
LDFLAGS += -Wl,-z,defs -Wl,--as-needed
%: