aboutsummaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorCharles Kerr <charles.kerr@canonical.com>2014-07-18 12:06:17 +0000
committerCI bot <ps-jenkins@lists.canonical.com>2014-07-18 12:06:17 +0000
commit87ba2b55ce8307bf021ce437ef9269c95cd1ddd9 (patch)
treea0fa0fb00632d79d2d46e7e51199044f4c207d10 /debian
parent1a497059179ece59d1cb7ad23b5d96b08dbf5837 (diff)
parentc8714f2ac53d8999d89a78810c6d60694482fdb6 (diff)
downloadayatana-indicator-datetime-87ba2b55ce8307bf021ce437ef9269c95cd1ddd9.tar.gz
ayatana-indicator-datetime-87ba2b55ce8307bf021ce437ef9269c95cd1ddd9.tar.bz2
ayatana-indicator-datetime-87ba2b55ce8307bf021ce437ef9269c95cd1ddd9.zip
make the gcc version explicit in debian/control and debian/rules.
Approved by: PS Jenkins bot
Diffstat (limited to 'debian')
-rw-r--r--debian/control5
-rwxr-xr-xdebian/rules5
2 files changed, 9 insertions, 1 deletions
diff --git a/debian/control b/debian/control
index 77e9241..9e7133e 100644
--- a/debian/control
+++ b/debian/control
@@ -2,8 +2,11 @@ Source: indicator-datetime
Section: misc
Priority: optional
Maintainer: Ubuntu Desktop Team <ubuntu-desktop@lists.ubuntu.com>
-# language-pack-en-base is for the unit tests s.t. we can test in 12h and 24h locales
+# g++-4.9: since we use c++11 features, explicitly select a g++ version
+# to protect from ABI breaks in libstdc++
+# language-pack-en-base: needed so unit tests can use 12h and 24h locales
Build-Depends: cmake,
+ g++-4.9,
dbus,
dbus-test-runner,
python3-dbusmock,
diff --git a/debian/rules b/debian/rules
index d2889aa..cf940f5 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,5 +1,10 @@
#!/usr/bin/make -f
+# Explicitly selecting a G{CC,++}-version here to avoid accidental
+# ABI breaks introduced by toolchain updates.
+export CC=$(DEB_HOST_GNU_TYPE)-gcc-4.9
+export CXX=$(DEB_HOST_GNU_TYPE)-g++-4.9
+
LDFLAGS += -Wl,-z,defs -Wl,--as-needed
%: