aboutsummaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorMathieu Trudel-Lapierre <mathieu@canonical.com>2012-01-13 00:03:36 +0100
committerMathieu Trudel-Lapierre <mathieu@canonical.com>2012-01-13 00:03:36 +0100
commit91fead5245d4c8cecac084f1e4d2837a49b831c3 (patch)
treef54746d543e13eee71c87c64c217c7eff3966a73 /debian
parent2839a0288cf121e9de202a7938ac52b0238f9f12 (diff)
downloadayatana-indicator-datetime-91fead5245d4c8cecac084f1e4d2837a49b831c3.tar.gz
ayatana-indicator-datetime-91fead5245d4c8cecac084f1e4d2837a49b831c3.tar.bz2
ayatana-indicator-datetime-91fead5245d4c8cecac084f1e4d2837a49b831c3.zip
* Rebuild for the new e-d-s libraries.
* debian/patches/gtk_box_api.patch: port gtk_hbox_new() to gtk_box_new() if building for GTK3, no change if building against GTK2.
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog8
-rw-r--r--debian/patches/gtk_box_api.patch41
-rw-r--r--debian/patches/series1
3 files changed, 50 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index 767d2ec..4c7d39b 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,11 @@
+indicator-datetime (0.3.1-0ubuntu3) UNRELEASED; urgency=low
+
+ * Rebuild for the new e-d-s libraries.
+ * debian/patches/gtk_box_api.patch: port gtk_hbox_new() to gtk_box_new() if
+ building for GTK3, no change if building against GTK2.
+
+ -- Mathieu Trudel-Lapierre <mathieu-tl@ubuntu.com> Thu, 12 Jan 2012 23:23:36 +0100
+
indicator-datetime (0.3.1-0ubuntu2) precise; urgency=low
* debian/patches/lp_802384.patch
diff --git a/debian/patches/gtk_box_api.patch b/debian/patches/gtk_box_api.patch
new file mode 100644
index 0000000..0dd28f0
--- /dev/null
+++ b/debian/patches/gtk_box_api.patch
@@ -0,0 +1,41 @@
+From: Mathieu Trudel-Lapierre <mathieu.trudel-lapierre@canonical.com>
+Subject: Port to the new gtk_box_new() instead of gtk_hbox_new().
+
+Index: indicator-datetime/src/indicator-datetime.c
+===================================================================
+--- indicator-datetime.orig/src/indicator-datetime.c 2012-01-12 23:59:50.815675283 +0100
++++ indicator-datetime/src/indicator-datetime.c 2012-01-13 00:02:24.083668449 +0100
+@@ -34,6 +34,7 @@
+ #include <glib-object.h>
+ #include <glib/gi18n-lib.h>
+ #include <gio/gio.h>
++#include <gtk/gtk.h>
+
+ /* Indicator Stuff */
+ #include <libindicator/indicator.h>
+@@ -1261,7 +1262,12 @@
+
+ mi_data->gmi = gtk_menu_item_new();
+
++#if GTK_CHECK_VERSION(3, 2, 0)
++ GtkWidget * hbox = gtk_box_new(GTK_ORIENTATION_HORIZONTAL, 4);
++ gtk_box_set_homogeneous (GTK_BOX(hbox), FALSE);
++#else
+ GtkWidget * hbox = gtk_hbox_new(FALSE, 4);
++#endif
+
+ /* Icon, probably someone's face or avatar on an IM */
+ mi_data->icon = gtk_image_new();
+@@ -1472,7 +1478,12 @@
+ gtk_check_menu_item_set_active(GTK_CHECK_MENU_ITEM(mi_data->gmi),
+ dbusmenu_menuitem_property_get_bool(newitem, TIMEZONE_MENUITEM_PROP_RADIO));
+
++#if GTK_CHECK_VERSION(3, 2, 0)
++ GtkWidget * hbox = gtk_box_new(GTK_ORIENTATION_HORIZONTAL, 4);
++ gtk_box_set_homogeneous (GTK_BOX(hbox), FALSE);
++#else
+ GtkWidget * hbox = gtk_hbox_new(FALSE, 4);
++#endif
+
+ /* Label, probably a username, chat room or mailbox name */
+ mi_data->label = gtk_label_new("");
diff --git a/debian/patches/series b/debian/patches/series
index d70dbda..aa1e0b7 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -1,2 +1,3 @@
lp_844741.patch
lp_802384.patch
+gtk_box_api.patch