aboutsummaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorMathieu Trudel-Lapierre <mathieu-tl@ubuntu.com>2012-11-16 15:40:12 -0500
committerMathieu Trudel-Lapierre <mathieu-tl@ubuntu.com>2012-11-16 15:40:12 -0500
commitb3c1c09b14cd358f830dd8a486bfddaf17d014de (patch)
treee5199f66bada7156ef822fe36478008f491af70e /debian
parent346b8038538627d86cc653c2c24fbf54a7d569f0 (diff)
downloadayatana-indicator-datetime-b3c1c09b14cd358f830dd8a486bfddaf17d014de.tar.gz
ayatana-indicator-datetime-b3c1c09b14cd358f830dd8a486bfddaf17d014de.tar.bz2
ayatana-indicator-datetime-b3c1c09b14cd358f830dd8a486bfddaf17d014de.zip
* debian/rules:
- Switch to using the dh sequencer instead of cdbs rules, adjust targets accordingly.
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog3
-rwxr-xr-xdebian/rules14
2 files changed, 10 insertions, 7 deletions
diff --git a/debian/changelog b/debian/changelog
index fec6948..7657555 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -7,6 +7,9 @@ indicator-datetime (12.10.3-0ubuntu1) UNRELEASED; urgency=low
- Drop Build-Depends on cdbs, bump debhelper to (>= 9).
- Update Vcs-Bzr and Vcs-Browser, add a notice for uploaders.
* debian/compat: bump compat level to 9.
+ * debian/rules:
+ - Switch to using the dh sequencer instead of cdbs rules, adjust targets
+ accordingly.
-- Mathieu Trudel-Lapierre <mathieu-tl@ubuntu.com> Fri, 16 Nov 2012 15:17:20 -0500
diff --git a/debian/rules b/debian/rules
index 135786f..81726a1 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,18 +1,18 @@
#!/usr/bin/make -f
-include /usr/share/cdbs/1/rules/patchsys-quilt.mk
-include /usr/share/cdbs/1/rules/autoreconf.mk
-include /usr/share/cdbs/1/rules/debhelper.mk
-include /usr/share/cdbs/1/class/gnome.mk
+LDFLAGS += -Wl,-z,defs -Wl,--as-needed
-DEB_CONFIGURE_EXTRA_FLAGS = --disable-static
+%:
+ dh $@ --with quilt,autoreconf
-LDFLAGS += -Wl,-z,defs -Wl,--as-needed
+override_dh_auto_configure:
+ dh_auto_configure -- --disable-static
-common-install-arch::
+override_dh_install:
find debian/indicator-datetime -name \*.la -delete
find debian/indicator-datetime -name \*.a -delete
cd po; intltool-update --pot --verbose
+ dh_install --fail-missing
# Language packs
for d in $$(find debian/indicator-datetime -type f \( -name "*.desktop" -o -name "*.directory" \) ); do \
sed -ri '/^(Name|GenericName|Comment|X-GNOME-FullName)\[/d' $$d; \