aboutsummaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorCharles Kerr <charles.kerr@canonical.com>2013-12-13 12:20:58 -0600
committerCharles Kerr <charles.kerr@canonical.com>2013-12-13 12:20:58 -0600
commitb91dc2ac50d421d29e22bac9c9564029ba64350d (patch)
tree23dae184a48b6ee3659cf2c7163d31fcf8d56f6c /debian
parent080af76066c8781b4b6dbfcc447c13fb0d1bb28c (diff)
downloadayatana-indicator-datetime-b91dc2ac50d421d29e22bac9c9564029ba64350d.tar.gz
ayatana-indicator-datetime-b91dc2ac50d421d29e22bac9c9564029ba64350d.tar.bz2
ayatana-indicator-datetime-b91dc2ac50d421d29e22bac9c9564029ba64350d.zip
try adding a build-dep of language-pack-en-base instead of configuring the locales in the unit test sandbox. (h/t seb)
Diffstat (limited to 'debian')
-rw-r--r--debian/control2
-rw-r--r--debian/locale-gen31
-rwxr-xr-xdebian/rules3
3 files changed, 2 insertions, 34 deletions
diff --git a/debian/control b/debian/control
index ade7f2e..d9d4f56 100644
--- a/debian/control
+++ b/debian/control
@@ -2,12 +2,14 @@ Source: indicator-datetime
Section: misc
Priority: optional
Maintainer: Ubuntu Desktop Team <ubuntu-desktop@lists.ubuntu.com>
+# language-pack-en-base is for the unit tests s.t. we can test in 12h and 24h locales
Build-Depends: cmake,
dbus,
debhelper (>= 9),
dh-translations,
intltool (>= 0.35.0),
gnome-common,
+ language-pack-en-base,
libxorg-gtest-dev,
libgtest-dev,
libglib2.0-dev (>= 2.35.4),
diff --git a/debian/locale-gen b/debian/locale-gen
deleted file mode 100644
index 437dec5..0000000
--- a/debian/locale-gen
+++ /dev/null
@@ -1,31 +0,0 @@
-#!/bin/sh
-
-LOCPATH=`pwd`/locales
-export LOCPATH
-
-[ -d $LOCPATH ] || mkdir -p $LOCPATH
-
-umask 022
-
-echo "Generating locales..."
-while read locale charset; do
- case $locale in \#*) continue;; esac
- [ -n "$locale" -a -n "$charset" ] || continue
- echo -n " `echo $locale | sed 's/\([^.\@]*\).*/\1/'`"
- echo -n ".$charset"
- echo -n `echo $locale | sed 's/\([^\@]*\)\(\@.*\)*/\2/'`
- echo -n '...'
- if [ -f $LOCPATH/$locale ]; then
- input=$locale
- else
- input=`echo $locale | sed 's/\([^.]*\)[^@]*\(.*\)/\1\2/'`
- fi
- localedef -i $input -c -f $charset $LOCPATH/$locale #-A /etc/locale.alias
- echo ' done'; \
-done <<EOF
-# Put the list of locales you need here:
-en_GB.utf8 UTF-8
-en_US.utf8 UTF-8
-EOF
-
-echo "Generation complete."
diff --git a/debian/rules b/debian/rules
index ea10b93..0e7a91f 100755
--- a/debian/rules
+++ b/debian/rules
@@ -14,6 +14,3 @@ override_dh_install:
echo "X-Ubuntu-Gettext-Domain=indicator-datetime" >> $$d; \
done;
-override_dh_auto_test:
- sh debian/locale-gen
- LOCPATH="$(CURDIR)/locales" dh_auto_test