aboutsummaryrefslogtreecommitdiff
path: root/panel/CMakeLists.txt
diff options
context:
space:
mode:
authorRobert Ancell <robert.ancell@canonical.com>2014-01-10 14:45:41 +1300
committerRobert Ancell <robert.ancell@canonical.com>2014-01-10 14:45:41 +1300
commit282993043650b14736443d9a100311c1fdd1f7d4 (patch)
tree63da37d9ca91d29819ff3ede836cd1a7f4a88dfe /panel/CMakeLists.txt
parent2c8955bb8c4c2d6914255d914bf2460dfd2723d7 (diff)
downloadayatana-indicator-datetime-282993043650b14736443d9a100311c1fdd1f7d4.tar.gz
ayatana-indicator-datetime-282993043650b14736443d9a100311c1fdd1f7d4.tar.bz2
ayatana-indicator-datetime-282993043650b14736443d9a100311c1fdd1f7d4.zip
Support both gnome-control-center and unity-control-center
Diffstat (limited to 'panel/CMakeLists.txt')
-rw-r--r--panel/CMakeLists.txt25
1 files changed, 0 insertions, 25 deletions
diff --git a/panel/CMakeLists.txt b/panel/CMakeLists.txt
deleted file mode 100644
index b3fcc7b..0000000
--- a/panel/CMakeLists.txt
+++ /dev/null
@@ -1,25 +0,0 @@
-set (PANEL_LIB "indicator-datetime")
-
-add_definitions (-DPKGDATADIR="${CMAKE_INSTALL_PREFIX}/${CMAKE_INSTALL_DATADIR}/${CMAKE_PROJECT_NAME}")
-
-add_library (${PANEL_LIB} SHARED
- datetime-prefs.c
- datetime-prefs-locations.c
- datetime-prefs-locations.h
- ${CMAKE_SOURCE_DIR}/src/utils.c
- ${CMAKE_SOURCE_DIR}/src/utils.h
- ${CMAKE_SOURCE_DIR}/src/settings-shared.h)
-
-include_directories (${PANEL_DEPS_INCLUDE_DIRS})
-
-link_directories (${PANEL_DEPS_LIBRARY_DIRS})
-
-set_property (TARGET ${PANEL_LIB}
- APPEND_STRING PROPERTY COMPILE_FLAGS
- " -g ${CC_WARNING_ARGS} ${GCOV_FLAGS}")
-
-target_link_libraries (${PANEL_LIB} ${PANEL_DEPS_LIBRARIES} ${GCOV_LIBS})
-
-install (TARGETS ${PANEL_LIB}
- DESTINATION ${CMAKE_INSTALL_LIBDIR}/control-center-1/panels)
-