aboutsummaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorRobert Tari <robert@tari.in>2022-02-11 14:25:31 +0100
committerRobert Tari <robert@tari.in>2022-02-11 14:25:31 +0100
commit0ae2ec89845d2f22eab82f4bd43d5222a785ee6c (patch)
treeebe265e83fd9aeb6407e9ba05125d7cbbba3163b /src/CMakeLists.txt
parentb439ad041ff4478453f0bd4e00f55224d653c69b (diff)
downloadayatana-indicator-datetime-0ae2ec89845d2f22eab82f4bd43d5222a785ee6c.tar.gz
ayatana-indicator-datetime-0ae2ec89845d2f22eab82f4bd43d5222a785ee6c.tar.bz2
ayatana-indicator-datetime-0ae2ec89845d2f22eab82f4bd43d5222a785ee6c.zip
Clean up compilation flags
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt8
1 files changed, 0 insertions, 8 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 5409c91..4131f22 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -54,13 +54,6 @@ if (ENABLE_LOMIRI_FEATURES)
/usr/share/accountsservice/interfaces/com.lomiri.touch.AccountsService.Sound.xml)
endif()
-# add warnings/coverage info on handwritten files
-# but not the autogenerated ones...
-set_source_files_properties(${SERVICE_CXX_SOURCES}
- PROPERTIES COMPILE_FLAGS ${COMPILE_FLAGS})
-set_source_files_properties(${SERVICE_C_SOURCES}
- PROPERTIES COMPILE_FLAGS ${COMPILE_FLAGS})
-
# add the bin dir to our include path so our code can find the generated header files
include_directories (${CMAKE_CURRENT_BINARY_DIR})
@@ -69,6 +62,5 @@ include_directories (${CMAKE_SOURCE_DIR})
link_directories (${SERVICE_DEPS_LIBRARY_DIRS})
add_executable (${SERVICE_EXEC} main.cpp)
-set_source_files_properties(${SERVICE_SOURCES} main.cpp PROPERTIES COMPILE_FLAGS ${COMPILE_FLAGS})
target_link_libraries (${SERVICE_EXEC} ${SERVICE_LIB} ${SERVICE_DEPS_LIBRARIES})
install (TARGETS ${SERVICE_EXEC} RUNTIME DESTINATION ${CMAKE_INSTALL_FULL_PKGLIBEXECDIR})