aboutsummaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorMike Gabriel <mike.gabriel@das-netzwerkteam.de>2021-12-03 15:40:21 +0100
committerMike Gabriel <mike.gabriel@das-netzwerkteam.de>2021-12-03 15:40:21 +0100
commit291efbd3b225c0760b9407370e1643c1b239aff8 (patch)
treefd81509cf38cea799e8f45da4a93f519b1fdf8c8 /src/CMakeLists.txt
parent87bbf6da491fbbaa5b0d4babe3d3ceb270820695 (diff)
parent22268331b662758c85847826fe7e94d9a000aa70 (diff)
downloadayatana-indicator-datetime-291efbd3b225c0760b9407370e1643c1b239aff8.tar.gz
ayatana-indicator-datetime-291efbd3b225c0760b9407370e1643c1b239aff8.tar.bz2
ayatana-indicator-datetime-291efbd3b225c0760b9407370e1643c1b239aff8.zip
Merge branch 'tari01-pr/add-lomiri-features-flag'
Attributes GH PR #82: https://github.com/AyatanaIndicators/ayatana-indicator-datetime/pull/82
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt6
1 files changed, 3 insertions, 3 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index d6d6844..5409c91 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -47,11 +47,11 @@ set(SERVICE_GENERATED_SOURCES)
add_gdbus_codegen(SERVICE_GENERATED_SOURCES dbus-alarm-properties
org.ayatana.indicator
${CMAKE_SOURCE_DIR}/data/org.ayatana.indicator.datetime.AlarmProperties.xml)
-if(LOMIRI_SCHEMAS_FOUND)
+
+if (ENABLE_LOMIRI_FEATURES)
add_gdbus_codegen(SERVICE_GENERATED_SOURCES dbus-accounts-sound
com.lomiri.touch
/usr/share/accountsservice/interfaces/com.lomiri.touch.AccountsService.Sound.xml)
- add_definitions (-DHAS_LOMIRI_SCHEMAS)
endif()
# add warnings/coverage info on handwritten files
@@ -70,5 +70,5 @@ link_directories (${SERVICE_DEPS_LIBRARY_DIRS})
add_executable (${SERVICE_EXEC} main.cpp)
set_source_files_properties(${SERVICE_SOURCES} main.cpp PROPERTIES COMPILE_FLAGS ${COMPILE_FLAGS})
-target_link_libraries (${SERVICE_EXEC} ${SERVICE_LIB} ${SERVICE_DEPS_LIBRARIES} ${URLDISPATCHER_LIBRARIES})
+target_link_libraries (${SERVICE_EXEC} ${SERVICE_LIB} ${SERVICE_DEPS_LIBRARIES})
install (TARGETS ${SERVICE_EXEC} RUNTIME DESTINATION ${CMAKE_INSTALL_FULL_PKGLIBEXECDIR})